Bug 19620 - REGRESSION: GoogleDocs: Font size change doesn't work first time
Summary: REGRESSION: GoogleDocs: Font size change doesn't work first time
Status: RESOLVED INVALID
Alias: None
Product: WebKit
Classification: Unclassified
Component: HTML Editing (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.5
: P2 Normal
Assignee: Nobody
URL:
Keywords: GoogleBug, Regression
Depends on:
Blocks:
 
Reported: 2008-06-17 15:21 PDT by Justin Garcia
Modified: 2008-11-04 12:16 PST (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Justin Garcia 2008-06-17 15:21:27 PDT
Go to http://docs.google.com/
Create a new document
Type "hello"
Select All
Change the font size from 10pt to 12pt

The font size doesn't change and the select becomes a caret at the beginning of the document.  Select All again and change from 10pt to 12pt.  The font size changes but you can no longer select text in the document.
Comment 1 Justin Garcia 2008-06-17 15:25:11 PDT
The second part (the text becoming unselectable was because of a user style sheet I had enabled to test for another bug.  But the first part (the font size not changing and the selection becoming a caret) is a real bug.
Comment 2 Justin Garcia 2008-06-17 15:41:09 PDT
Seems like a bug in GoogleDocs.  On the first font size change they are:

Inserting an empty text node before the text node that contains "hello"
Clearing the selection with Selection::removeAllRanges()
Setting a selection with Selection::addRange(r) where r is [emptyTextNode, 0] to [emptyTextNode, 0]
Comment 3 Julie Parent 2008-06-20 14:22:00 PDT
Yup, they are aware.  Fix should go out with their next push.
Comment 4 Maciej Stachowiak 2008-11-04 12:16:34 PST
Closing as INVALID since this turned out to be a Google bug and was fixed on that end.