Bug 196047 - Web Inspector: create CommandLineAPIHost lazily like the other agents
Summary: Web Inspector: create CommandLineAPIHost lazily like the other agents
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (show other bugs)
Version: WebKit Nightly Build
Hardware: All All
: P2 Normal
Assignee: Devin Rousso
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2019-03-20 17:50 PDT by Devin Rousso
Modified: 2019-06-06 16:31 PDT (History)
12 users (show)

See Also:


Attachments
Patch (9.36 KB, patch)
2019-05-05 23:06 PDT, Devin Rousso
no flags Details | Formatted Diff | Diff
Archive of layout-test-results from ews101 for mac-highsierra (922.00 KB, application/zip)
2019-05-05 23:56 PDT, Build Bot
no flags Details
Archive of layout-test-results from ews106 for mac-highsierra-wk2 (1001.17 KB, application/zip)
2019-05-06 00:04 PDT, Build Bot
no flags Details
Archive of layout-test-results from ews215 for win-future (8.78 MB, application/zip)
2019-05-06 00:11 PDT, Build Bot
no flags Details
Archive of layout-test-results from ews112 for mac-highsierra (955.91 KB, application/zip)
2019-05-06 00:17 PDT, Build Bot
no flags Details
Archive of layout-test-results from ews123 for ios-simulator-wk2 (681.21 KB, application/zip)
2019-05-06 00:31 PDT, Build Bot
no flags Details
Patch (9.37 KB, patch)
2019-05-13 12:06 PDT, Devin Rousso
no flags Details | Formatted Diff | Diff
Archive of layout-test-results from ews102 for mac-highsierra (900.50 KB, application/zip)
2019-05-13 12:59 PDT, Build Bot
no flags Details
Archive of layout-test-results from ews104 for mac-highsierra-wk2 (942.63 KB, application/zip)
2019-05-13 13:06 PDT, Build Bot
no flags Details
Patch (8.09 KB, patch)
2019-05-13 13:20 PDT, Devin Rousso
no flags Details | Formatted Diff | Diff
Patch (8.08 KB, patch)
2019-05-13 17:53 PDT, Devin Rousso
no flags Details | Formatted Diff | Diff
Archive of layout-test-results from ews103 for mac-highsierra (931.50 KB, application/zip)
2019-05-13 18:45 PDT, Build Bot
no flags Details
Archive of layout-test-results from ews104 for mac-highsierra-wk2 (959.78 KB, application/zip)
2019-05-13 18:51 PDT, Build Bot
no flags Details
Archive of layout-test-results from ews125 for ios-simulator-wk2 (1.12 MB, application/zip)
2019-05-13 18:54 PDT, Build Bot
no flags Details
Archive of layout-test-results from ews116 for mac-highsierra (945.90 KB, application/zip)
2019-05-13 19:05 PDT, Build Bot
no flags Details
Archive of layout-test-results from ews212 for win-future (7.94 MB, application/zip)
2019-05-13 21:17 PDT, Build Bot
no flags Details
Patch (9.57 KB, patch)
2019-05-15 01:07 PDT, Devin Rousso
no flags Details | Formatted Diff | Diff
Patch (9.57 KB, patch)
2019-05-15 04:04 PDT, Devin Rousso
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Devin Rousso 2019-03-20 17:50:19 PDT
We don't need the command line API to be available until we connect a frontend.
Comment 1 Radar WebKit Bug Importer 2019-03-20 17:50:36 PDT
<rdar://problem/49087835>
Comment 2 Devin Rousso 2019-05-05 23:06:39 PDT
Created attachment 369100 [details]
Patch
Comment 3 Build Bot 2019-05-05 23:56:50 PDT Comment hidden (obsolete)
Comment 4 Build Bot 2019-05-05 23:56:52 PDT Comment hidden (obsolete)
Comment 5 Build Bot 2019-05-06 00:04:51 PDT Comment hidden (obsolete)
Comment 6 Build Bot 2019-05-06 00:04:53 PDT Comment hidden (obsolete)
Comment 7 Build Bot 2019-05-06 00:11:00 PDT Comment hidden (obsolete)
Comment 8 Build Bot 2019-05-06 00:11:02 PDT Comment hidden (obsolete)
Comment 9 Build Bot 2019-05-06 00:17:03 PDT Comment hidden (obsolete)
Comment 10 Build Bot 2019-05-06 00:17:05 PDT Comment hidden (obsolete)
Comment 11 Build Bot 2019-05-06 00:31:04 PDT Comment hidden (obsolete)
Comment 12 Build Bot 2019-05-06 00:31:05 PDT Comment hidden (obsolete)
Comment 13 Devin Rousso 2019-05-13 12:06:25 PDT
Created attachment 369759 [details]
Patch

Rebase, to see if the test failures are actually caused by this change.
Comment 14 Build Bot 2019-05-13 12:59:00 PDT Comment hidden (obsolete)
Comment 15 Build Bot 2019-05-13 12:59:02 PDT Comment hidden (obsolete)
Comment 16 Build Bot 2019-05-13 13:05:58 PDT Comment hidden (obsolete)
Comment 17 Build Bot 2019-05-13 13:06:00 PDT Comment hidden (obsolete)
Comment 18 Devin Rousso 2019-05-13 13:20:16 PDT
Created attachment 369771 [details]
Patch
Comment 19 Devin Rousso 2019-05-13 17:53:27 PDT
Created attachment 369805 [details]
Patch
Comment 20 Build Bot 2019-05-13 18:45:44 PDT Comment hidden (obsolete)
Comment 21 Build Bot 2019-05-13 18:45:46 PDT Comment hidden (obsolete)
Comment 22 Build Bot 2019-05-13 18:51:43 PDT Comment hidden (obsolete)
Comment 23 Build Bot 2019-05-13 18:51:45 PDT Comment hidden (obsolete)
Comment 24 Build Bot 2019-05-13 18:54:15 PDT Comment hidden (obsolete)
Comment 25 Build Bot 2019-05-13 18:54:17 PDT Comment hidden (obsolete)
Comment 26 Build Bot 2019-05-13 19:05:09 PDT Comment hidden (obsolete)
Comment 27 Build Bot 2019-05-13 19:05:11 PDT Comment hidden (obsolete)
Comment 28 Build Bot 2019-05-13 21:17:06 PDT Comment hidden (obsolete)
Comment 29 Build Bot 2019-05-13 21:17:09 PDT Comment hidden (obsolete)
Comment 30 Devin Rousso 2019-05-15 01:07:44 PDT
Created attachment 369937 [details]
Patch
Comment 31 Devin Rousso 2019-05-15 04:04:01 PDT
Created attachment 369945 [details]
Patch
Comment 32 WebKit Commit Bot 2019-06-06 16:31:46 PDT
Comment on attachment 369945 [details]
Patch

Clearing flags on attachment: 369945

Committed r246177: <https://trac.webkit.org/changeset/246177>
Comment 33 WebKit Commit Bot 2019-06-06 16:31:48 PDT
All reviewed patches have been landed.  Closing bug.