Bug 19599 - Wedding site fails due to x-domain access
Summary: Wedding site fails due to x-domain access
Status: RESOLVED WONTFIX
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.5
: P2 Normal
Assignee: Nobody
URL: http://www.sean-and-stephanie.com/
Keywords:
Depends on:
Blocks:
 
Reported: 2008-06-16 23:47 PDT by Eric Seidel (no email)
Modified: 2010-01-02 09:40 PST (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eric Seidel (no email) 2008-06-16 23:47:26 PDT
Wedding site fails due to x-domain access

Works in FF3.  I think it works in 3.1 too, I'm using 4.0dev preview.

Unsafe JavaScript attempt to access frame with URL http://wedorama.com/sean-and-stephanie/ from frame with URL http://www.sean-and-stephanie.com/. Domains, protocols and ports must match.
 Unsafe JavaScript attempt to access frame with URL http://www.sean-and-stephanie.com/ from frame with URL http://wedorama.com/sean-and-stephanie/. Domains, protocols and ports must match.
 Unsafe JavaScript attempt to access frame with URL http://wedorama.com/sean-and-stephanie/ from frame with URL http://www.sean-and-stephanie.com/. Domains, protocols and ports must match.
Comment 1 Eric Seidel (no email) 2008-06-17 00:02:40 PDT
Btw, you can tell when it fails because you'll see a picture in a box, and then an empty blue box.  When the site works, you see text in the blue box.
Comment 2 Eric Seidel (no email) 2008-06-17 00:03:48 PDT
Bah.  I'm seeing it occasionally work in Safari 4DP.  I wonder if this could be a site or timing issue.  That some document.location = "sean-and-stephanie.com" call isn't happening in time, or something.
Comment 3 Eric Seidel (no email) 2008-06-17 00:04:12 PDT
Btw, you also know it's working when you hear music. :)
Comment 4 Adam Barth 2010-01-02 09:40:27 PST
http://www.sean-and-stephanie.com/ no longer exists so I can't investigate this bug.  :(