Bug 195931 - [WPE] Fix build warnings because of missing an argument when initializing wpe_input_axis_event
Summary: [WPE] Fix build warnings because of missing an argument when initializing wp...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WPE WebKit (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Gyuyoung Kim
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-03-18 20:45 PDT by Gyuyoung Kim
Modified: 2019-03-19 18:38 PDT (History)
6 users (show)

See Also:


Attachments
Patch (2.12 KB, patch)
2019-03-18 21:01 PDT, Gyuyoung Kim
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Gyuyoung Kim 2019-03-18 20:45:55 PDT
There are still build warning when building wpe port. I think that these build warnings have been caused by missing to set an argument for the modifier parameter of wpe_input_axis_event.


/home/gyuyoung/LGE/starfish/webkit/WebKit/Source/WebKit/UIProcess/API/wpe/ScrollGestureController.cpp: In member function ‘bool WebKit::ScrollGestureController::handleEvent(const wpe_input_touch_event_raw*)’:
/home/gyuyoung/LGE/starfish/webkit/WebKit/Source/WebKit/UIProcess/API/wpe/ScrollGestureController.cpp:59:13: warning: missing initializer for member ‘wpe_input_axis_event::modifiers’ [-Wmissing-field-initializers]
             };
             ^
/home/gyuyoung/LGE/starfish/webkit/WebKit/Source/WebKit/UIProcess/API/wpe/ScrollGestureController.cpp:71:13: warning: missing initializer for member ‘wpe_input_axis_event::modifiers’ [-Wmissing-field-initializers]
             };
Comment 1 Gyuyoung Kim 2019-03-18 21:01:03 PDT
Created attachment 365118 [details]
Patch
Comment 2 Gyuyoung Kim 2019-03-18 23:46:17 PDT
If 0 is a wrong value for the modifier, please let me know.
Comment 3 Adrian Perez 2019-03-19 06:20:06 PDT
Comment on attachment 365118 [details]
Patch

Patch LGTM → informal r+
Comment 4 Gyuyoung Kim 2019-03-19 18:13:12 PDT
Thanks Adrian and Michael!
Comment 5 WebKit Commit Bot 2019-03-19 18:38:18 PDT
Comment on attachment 365118 [details]
Patch

Clearing flags on attachment: 365118

Committed r243184: <https://trac.webkit.org/changeset/243184>
Comment 6 WebKit Commit Bot 2019-03-19 18:38:19 PDT
All reviewed patches have been landed.  Closing bug.