Bug 195887 - [WPE] Bump public API to wpe-1.0
Summary: [WPE] Bump public API to wpe-1.0
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WPE WebKit (show other bugs)
Version: Other
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Adrian Perez
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-03-18 08:02 PDT by Adrian Perez
Modified: 2019-03-18 09:54 PDT (History)
7 users (show)

See Also:


Attachments
Patch (1.04 KB, patch)
2019-03-18 08:03 PDT, Adrian Perez
no flags Details | Formatted Diff | Diff
Patch v2 (92.99 KB, patch)
2019-03-18 08:57 PDT, Adrian Perez
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Adrian Perez 2019-03-18 08:02:04 PDT
Now it is a good moment to set the WPE WebKit API version to 1.0,
because applications will need to be updated and rebuilt anyway
due to libwpe and wpebackend-fdo bumping their API version recently
as well. 

Getting the API version out of the 0.x versions will also reflect
the fact that we intend to keep the API stable :)
Comment 1 Adrian Perez 2019-03-18 08:03:16 PDT
Created attachment 365015 [details]
Patch
Comment 2 Adrian Perez 2019-03-18 08:15:49 PDT
Comment on attachment 365015 [details]
Patch

Setting cq- because we need renaming the sections file for GTK-Doc,
see the EWS failure.
Comment 3 Adrian Perez 2019-03-18 08:57:31 PDT
Created attachment 365018 [details]
Patch v2
Comment 4 WebKit Commit Bot 2019-03-18 09:54:02 PDT
Comment on attachment 365018 [details]
Patch v2

Clearing flags on attachment: 365018

Committed r243073: <https://trac.webkit.org/changeset/243073>
Comment 5 WebKit Commit Bot 2019-03-18 09:54:04 PDT
All reviewed patches have been landed.  Closing bug.