Bug 195792 - REGRESSION(cairo-1.17.2) GraphicsContext::clipRoundedRect clips everything
Summary: REGRESSION(cairo-1.17.2) GraphicsContext::clipRoundedRect clips everything
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Platform (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-03-14 20:40 PDT by Fujii Hironori
Modified: 2019-03-28 18:49 PDT (History)
1 user (show)

See Also:


Attachments
repro (150 bytes, text/html)
2019-03-14 20:40 PDT, Fujii Hironori
no flags Details
simple cairo clipping program (5.61 KB, text/plain)
2019-03-18 00:33 PDT, Fujii Hironori
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Fujii Hironori 2019-03-14 20:40:42 PDT
Created attachment 364766 [details]
repro

[WinCairo] Texts are not drawn in blocks with border-radius and overflow-x:auto

Testing with WinCairo port trunk@242984 WK1 and WK2 BrowerWindow.
It seems that GTK port doesn't have this issue.
Comment 2 Don Olmstead 2019-03-17 20:52:30 PDT
Does it work with the previous cairo?
Comment 3 Fujii Hironori 2019-03-17 21:10:57 PDT
This issue can be fixed by replacing with cairo.dll of WinCairoRequirements v2018.11.27 (Cairo 1.16.0).
Comment 4 Fujii Hironori 2019-03-17 21:13:00 PDT
GraphicsContext::clipRoundedRect doesn't work as expected.
Comment 5 Fujii Hironori 2019-03-18 00:33:22 PDT
Created attachment 365003 [details]
simple cairo clipping program
Comment 6 Fujii Hironori 2019-03-18 01:10:37 PDT Comment hidden (obsolete)
Comment 7 Fujii Hironori 2019-03-18 03:24:29 PDT
I tested the repro with the latest vcpkg.

cairo 1.16.0 + pixman 0.38.0 (x86-windows): OK
cairo 1.17.2 + pixman 0.38.0 (x86-windows): NG
Comment 8 Fujii Hironori 2019-03-18 18:24:12 PDT
I had a mistake in comment#6. I redid the experiment on Linux.
I've confirmed this issue can be reproduced on Linux with cairo-1.17.2.tar.xz.
Comment 9 Fujii Hironori 2019-03-18 18:53:20 PDT
The upstream Cairo master branch has fixed this issue.
This is the commit.
https://gitlab.freedesktop.org/cairo/cairo/commit/2d1a137f3d27b60538c58b25e867288c7b0b61bc
Comment 10 Fujii Hironori 2019-03-28 18:49:15 PDT
https://github.com/WebKitForWindows/WinCairoRequirements/releases/tag/v2019.03.28

> Downgrades cairo to a previous version due to instability of the developer snapshot.

Fixed.