Bug 195729 - Optimize AsyncScrollingCoordinator::applyScrollingTreeLayerPositions() to do no work if no scrolling happened
Summary: Optimize AsyncScrollingCoordinator::applyScrollingTreeLayerPositions() to do ...
Status: RESOLVED DUPLICATE of bug 154399
Alias: None
Product: WebKit
Classification: Unclassified
Component: Scrolling (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2019-03-13 19:28 PDT by Simon Fraser (smfr)
Modified: 2019-06-06 09:50 PDT (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Simon Fraser (smfr) 2019-03-13 19:28:38 PDT
AsyncScrollingCoordinator::applyScrollingTreeLayerPositions should do nothing if there was no scrolling tree change since the last apply, just to avoid extra work.
Comment 1 Radar WebKit Bug Importer 2019-03-13 19:29:05 PDT
<rdar://problem/48874171>
Comment 2 Antti Koivisto 2019-06-06 09:50:21 PDT
This was fixed in <https://trac.webkit.org/changeset/246156>

*** This bug has been marked as a duplicate of bug 154399 ***