Bug 195684 - REGRESSION(PSON, r240660): Navigation over process boundary is flashy when using Cmd-left/right arrow to navigate
Summary: REGRESSION(PSON, r240660): Navigation over process boundary is flashy when us...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit2 (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Chris Dumez
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2019-03-13 10:27 PDT by Chris Dumez
Modified: 2019-03-13 13:32 PDT (History)
9 users (show)

See Also:


Attachments
Patch (21.72 KB, patch)
2019-03-13 12:07 PDT, Chris Dumez
no flags Details | Formatted Diff | Diff
Patch (21.76 KB, patch)
2019-03-13 13:05 PDT, Chris Dumez
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Dumez 2019-03-13 10:27:53 PDT
Navigation over process boundary is flashy when using Cmd-left/right arrow to navigate.
Comment 1 Chris Dumez 2019-03-13 10:28:07 PDT
<rdar://problem/48294714>
Comment 2 Chris Dumez 2019-03-13 12:07:37 PDT
Created attachment 364560 [details]
Patch
Comment 3 Antti Koivisto 2019-03-13 12:59:36 PDT
Comment on attachment 364560 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=364560&action=review

> Source/WebCore/ChangeLog:12
> +        When a navigation is triggered by JS (and not the client), we create the Navigation object in

Cmd-left/right arrow involves JS?

> Source/WebCore/ChangeLog:22
> +        This is a lot error prone, the WebProcess knows more accurately which history items it is going

"a lot error prone"
Comment 4 Chris Dumez 2019-03-13 13:01:35 PDT
Comment on attachment 364560 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=364560&action=review

>> Source/WebCore/ChangeLog:12
>> +        When a navigation is triggered by JS (and not the client), we create the Navigation object in
> 
> Cmd-left/right arrow involves JS?

Not JS but it is a navigation triggered by the WebProcess as opposed by the UIProcess. It seems to be the same code path as navigating via JS.
Comment 5 Chris Dumez 2019-03-13 13:05:30 PDT
Created attachment 364565 [details]
Patch
Comment 6 WebKit Commit Bot 2019-03-13 13:32:54 PDT
Comment on attachment 364565 [details]
Patch

Clearing flags on attachment: 364565

Committed r242903: <https://trac.webkit.org/changeset/242903>
Comment 7 WebKit Commit Bot 2019-03-13 13:32:56 PDT
All reviewed patches have been landed.  Closing bug.