Bug 19553 - Unexpected failures in date tests in trunk r34569
Summary: Unexpected failures in date tests in trunk r34569
Status: RESOLVED DUPLICATE of bug 4930
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh PowerPC OS X 10.4
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-06-15 06:23 PDT by Gabriel de Dietrich
Modified: 2009-05-17 23:42 PDT (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gabriel de Dietrich 2008-06-15 06:23:06 PDT
Hi!

I'm new into this, so I'm not exactly sure whether I should report svn trunk bugs. Anyway, I checked  the WebKit svn trunk out, built it, and ran the JavaScript tests to find that…

** Danger, Will Robinson! Danger! The following failures have been introduced:
        ecma/Date/15.9.5.31-1.js
        ecma_3/Date/15.9.5.6.js

Here are some extracts from actual.html:

Test List: All tests
Skip List: (none)
1135 test(s) selected, 1127 test(s) completed, 53 failures reported (4.7% failed)
Engine command line: "/Users/gabi/Development/WebKit/WebKitBuild/Release/jsc" 
OS type: Darwin Orlando.local 8.11.0 Darwin Kernel Version 8.11.0: Wed Oct 10 18:26:00 PDT 2007; root:xnu-792.24.17~1/RELEASE_PPC Power Macintosh powerpc
Testcase execution time: 1 minutes, 32 seconds.
Tests completed on Sun Jun 15 14:48:21 2008.

[...]

Testcase ecma/Date/15.9.5.31-1.js failed 
[ Next Failure | Top of Page ]

Failure messages were:
TDATE = new Date(946684800000);(TDATE).setUTCHours(1234567);TDATE.getHours() = 8 FAILED! expected: 9

[...]

Testcase ecma_3/Date/15.9.5.6.js failed 
[ Previous Failure | Next Failure | Top of Page ]

Failure messages were:
Date.parse(Mon Jan 01 1900 00:00:00 GMT+0100 (CET)).toLocaleDateString()) = -2209078800000 FAILED! expected: -2208992400000


Hope it helps…

Gabriel
Comment 1 Mark Rowe (bdash) 2008-06-15 19:54:32 PDT
What time zone is your computer in?  Several of the JavaScriptCore date tests will fail when run in a non US Pacific time zone.
Comment 2 Gabriel de Dietrich 2008-06-16 01:09:34 PDT
Central European Summer Time, that is currently UTC+2.
Comment 3 Eric Seidel (no email) 2009-05-17 23:42:35 PDT
This sounds like bug 4930 then.

*** This bug has been marked as a duplicate of 4930 ***