Bug 19486 - [Gtk] Setting font colours
Summary: [Gtk] Setting font colours
Status: RESOLVED DUPLICATE of bug 15597
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKitGTK (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC Linux
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on: 15597
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-11 11:20 PDT by Don Scorgie
Modified: 2009-04-09 12:10 PDT (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Don Scorgie 2008-06-11 11:20:56 PDT
Webkit does not seem to respect the theme font colours and provides no method of seeting the relevant colours.

This impacts on "high contrast inverse" themes.  These have white fonts on dark backgrounds.  When tested, this results in the correct dark background, but the text remain black (and hence unreadable).

In addition, some themes set the "link-color" property, which is not respected.

Ideally, webkit would take care of these, reading and setting direct from the theme however as a backup, the ability to set a property of WebKitWebSettings would be great.

Thanks
Comment 1 Christian Dywan 2009-04-09 12:10:19 PDT

*** This bug has been marked as a duplicate of 15597 ***