Bug 19482 - Webkit Nightly Crashes with multiple AJAX Heavy Sites open in tabs
Summary: Webkit Nightly Crashes with multiple AJAX Heavy Sites open in tabs
Status: RESOLVED INVALID
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.5
: P2 Major
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-06-11 09:17 PDT by Chris George
Modified: 2011-06-14 00:48 PDT (History)
2 users (show)

See Also:


Attachments
Bug report for JS Crash (45.45 KB, text/plain)
2008-06-11 09:18 PDT, Chris George
no flags Details
Non-Inquisitor installed Crashed (45.15 KB, text/plain)
2008-06-16 10:49 PDT, Chris George
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Chris George 2008-06-11 09:17:50 PDT
I'm not entirely positive how to recreate this other than going to sites that use a lot of AJAX and letting it fill up a buffer, with multiple AJAX heavy pages open in tabs [I usually have 3-4]. This happens to me about 2-3 times a day [in Safari 3.1.x as well] but never with the same set of sites open or the same order.

I've attached the stack trace so it will hopefully generate a better understanding of what's happening.
Comment 1 Chris George 2008-06-11 09:18:22 PDT
Created attachment 21627 [details]
Bug report for JS Crash
Comment 2 Alexey Proskuryakov 2008-06-12 21:34:55 PDT
Please try uninstalling Inquisitor and seeing if that helps. The attached crash report doesn't seem like something related to a bug that could persist from Safari 3.1.1 to recent nightlies (although it's hard to say for sure, of course).

For now, I'm resolving as INVALID because of Inquisitor (and it's certainly not a common experience to have frequent crashes with Safari 3.1.1!). Please feel free to re-open if you continue seeing the problem after uninstalling SIMBL and Inquisitor.
Comment 3 Chris George 2008-06-16 10:49:20 PDT
Created attachment 21732 [details]
Non-Inquisitor installed Crashed

This crash report came after SIMBL and Inquisitor were uninstalled.
Comment 4 Chris George 2008-06-16 10:50:05 PDT
Reopening because the same crash appeared after uninstalling inquisitor/SIMBL.
Comment 5 Gavin Barraclough 2011-06-14 00:48:49 PDT
I'm going to close this bug since (1) it is reporting an issue in a 3 year old Safari, and likely since been fixed, (2) the code has changed so much in the JS engine that the attached stack trace is going to be no help in tracking down an issue.

If you can still reproduce this crash, then please reopen, and attach an updated stack trace!

Many thanks,
G.