Bug 194554 - webkitpy: No option to only show unexpected failures in results.html for iPad
Summary: webkitpy: No option to only show unexpected failures in results.html for iPad
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Jonathan Bedard
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2019-02-12 13:05 PST by Jonathan Bedard
Modified: 2019-02-12 13:53 PST (History)
5 users (show)

See Also:


Attachments
Patch (2.74 KB, patch)
2019-02-12 13:27 PST, Jonathan Bedard
no flags Details | Formatted Diff | Diff
Patch for landing (2.74 KB, patch)
2019-02-12 13:34 PST, Jonathan Bedard
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Bedard 2019-02-12 13:05:41 PST
results.html for iPad should have an option to hid unexpected results. The root cause of this problem is the fact that Port.uses_test_expectations_file() returns 'false' for iPhone and iPad because the iphone-simulator and ipad-simulator directories do not exist.
Comment 1 Jonathan Bedard 2019-02-12 13:05:55 PST
<rdar://problem/47922442>
Comment 2 Jonathan Bedard 2019-02-12 13:27:45 PST
Created attachment 361828 [details]
Patch
Comment 3 Aakash Jain 2019-02-12 13:31:47 PST
Comment on attachment 361828 [details]
Patch

rs=me
Comment 4 Jonathan Bedard 2019-02-12 13:34:46 PST
Created attachment 361830 [details]
Patch for landing
Comment 5 WebKit Commit Bot 2019-02-12 13:53:06 PST
Comment on attachment 361830 [details]
Patch for landing

Clearing flags on attachment: 361830

Committed r241318: <https://trac.webkit.org/changeset/241318>
Comment 6 WebKit Commit Bot 2019-02-12 13:53:08 PST
All reviewed patches have been landed.  Closing bug.