Bug 194441 - stress/phantom-spread-forward-varargs.js.bytecode-cache failing on debug builds
Summary: stress/phantom-spread-forward-varargs.js.bytecode-cache failing on debug builds
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Tadeu Zagallo
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2019-02-08 10:44 PST by Saam Barati
Modified: 2019-02-14 09:38 PST (History)
17 users (show)

See Also:


Attachments
Patch (2.46 KB, patch)
2019-02-14 06:51 PST, Tadeu Zagallo
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Saam Barati 2019-02-08 10:44:47 PST
stress/phantom-spread-forward-varargs.js.bytecode-cache: ../../.helpers/bytecode-cache-test-helper.sh: line 28: 74832 Segmentation fault: 11  ../../.vm/JavaScriptCore.framework/Resources/jsc phantom-spread-forward-varargs.js --useFTLJIT=false --useFunctionDotArguments=true --validateExceptionChecks=true --useDollarVM=true --maxPerThreadStackUsage=1572864 --useFTLJIT=true
Comment 1 Alexey Proskuryakov 2019-02-12 15:56:09 PST
This looks like a crash. Saam, do you need assistance retrieving a crash log?
Comment 2 Saam Barati 2019-02-13 12:24:58 PST
(In reply to Alexey Proskuryakov from comment #1)
> This looks like a crash. Saam, do you need assistance retrieving a crash log?

Not sure. Tadeu, do you need a crashlog or were you able to reproduce this?
Comment 3 Tadeu Zagallo 2019-02-13 14:45:28 PST
No, that's ok, I can repro it. Thanks! I'm investigating it now.
Comment 4 Tadeu Zagallo 2019-02-14 06:51:55 PST
Created attachment 362012 [details]
Patch
Comment 5 WebKit Commit Bot 2019-02-14 09:37:28 PST
Comment on attachment 362012 [details]
Patch

Clearing flags on attachment: 362012

Committed r241550: <https://trac.webkit.org/changeset/241550>
Comment 6 WebKit Commit Bot 2019-02-14 09:37:30 PST
All reviewed patches have been landed.  Closing bug.
Comment 7 Radar WebKit Bug Importer 2019-02-14 09:38:31 PST
<rdar://problem/48076793>