Bug 194231 - when lowering AssertNotEmpty, create the value before creating the patchpoint
Summary: when lowering AssertNotEmpty, create the value before creating the patchpoint
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Robin Morisset
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2019-02-04 11:12 PST by Robin Morisset
Modified: 2019-02-04 17:36 PST (History)
6 users (show)

See Also:


Attachments
Patch (3.03 KB, patch)
2019-02-04 13:48 PST, Robin Morisset
no flags Details | Formatted Diff | Diff
Patch (3.08 KB, patch)
2019-02-04 13:53 PST, Robin Morisset
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Robin Morisset 2019-02-04 11:12:33 PST
rdar://problem/46447987
Comment 1 Robin Morisset 2019-02-04 13:48:37 PST
Created attachment 361094 [details]
Patch
Comment 2 Robin Morisset 2019-02-04 13:53:31 PST
Created attachment 361095 [details]
Patch
Comment 3 Build Bot 2019-02-04 16:35:02 PST
Comment on attachment 361095 [details]
Patch

Attachment 361095 [details] did not pass jsc-ews (mac):
Output: https://webkit-queues.webkit.org/results/11030286

New failing tests:
stress/ftl-get-by-id-getter-exception-interesting-live-state.js.ftl-eager
apiTests
Comment 4 Robin Morisset 2019-02-04 17:24:58 PST
I could not reproduce this failure, and according to sbarati@apple.com, this test is known to be flaky.
Comment 5 Saam Barati 2019-02-04 17:30:15 PST
Comment on attachment 361095 [details]
Patch

r=me
Comment 6 WebKit Commit Bot 2019-02-04 17:36:33 PST
Comment on attachment 361095 [details]
Patch

Clearing flags on attachment: 361095

Committed r240959: <https://trac.webkit.org/changeset/240959>
Comment 7 WebKit Commit Bot 2019-02-04 17:36:35 PST
All reviewed patches have been landed.  Closing bug.