Bug 19420 - WebKit hangs after clicking link or reloading
Summary: WebKit hangs after clicking link or reloading
Status: RESOLVED WORKSFORME
Alias: None
Product: WebKit
Classification: Unclassified
Component: Page Loading (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.5
: P2 Normal
Assignee: Nobody
URL: http://www.insidesocal.com/ucla/
Keywords:
Depends on:
Blocks:
 
Reported: 2008-06-06 16:45 PDT by mjwelch
Modified: 2013-02-12 20:20 PST (History)
2 users (show)

See Also:


Attachments
Activity Monitor sampling output during hang (25.45 KB, text/plain)
2008-06-06 19:59 PDT, mjwelch
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description mjwelch 2008-06-06 16:45:12 PDT
Initial page loads fine, but refreshes or clicking on links (either into new window, new tab, or same tab/window) hangs for several seconds with one CPU core spiked to 100% utilization.  Browser is unresponsive until the page eventually loads.

Snippet from Activity Monitor sample reports majority of time spent in:

WebCore::JSNodeList::getValueProperty(KJS::ExecState*, int) const
Comment 1 Mark Rowe (bdash) 2008-06-06 17:37:25 PDT
Can you please attach the entire "sample" output?
Comment 2 mjwelch 2008-06-06 19:59:22 PDT
Created attachment 21541 [details]
Activity Monitor sampling output during hang
Comment 3 Sanford Selznick 2013-02-07 19:13:28 PST
I can reproduce this by reloading <http://nightly.webkit.org/start/trunk/142133> three times.  On the third time I get a blank page.

It seems to happen on some sites with JS + DHTML.

The only way to fix it is to quit and re-launch webkit.  Closing tabs and re-opening them does not fix the problem.  Once a page stops loading, it never loads again until quit+relaunch.

Version 6.0.2 (8536.26.17, 537+)  Mac OS X 10.8.2.
Comment 4 Alexey Proskuryakov 2013-02-12 19:39:51 PST
There is a new bug filed about reloading <http://nightly.webkit.org/start/trunk/142133> three times. I think that we should close this old bug to avoid confusion. I cannot reproduce with Safari 6.0.2.
Comment 5 Sanford Selznick 2013-02-12 20:20:15 PST
I agree.  The new bug URL is https://bugs.webkit.org/show_bug.cgi?id=109249 for those interested.   The bug detailed in 19420 is different.