Bug 194018 - STP constantly hangs/crashes when navigating back to previous pages
Summary: STP constantly hangs/crashes when navigating back to previous pages
Status: RESOLVED DUPLICATE of bug 193779
Alias: None
Product: WebKit
Classification: Unclassified
Component: Page Loading (show other bugs)
Version: Safari Technology Preview
Hardware: Mac macOS 10.14
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2019-01-30 06:47 PST by johnt519
Modified: 2019-02-03 20:24 PST (History)
3 users (show)

See Also:


Attachments
Crash Log (126.50 KB, text/plain)
2019-01-30 06:47 PST, johnt519
no flags Details
Sample of S.T.P Process when beach balled. (119.02 KB, text/plain)
2019-01-30 06:47 PST, johnt519
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description johnt519 2019-01-30 06:47:09 PST
Created attachment 360577 [details]
Crash Log

When navigating in Safari Tech Preview, frequently after navigating "back" to a page, or trying to click a link to go to another page, the app will just freeze with the spinning beach ball. Often it will crash.

I've included the latest crash report, as well as a Sample when I received the latest beachball.

Sample:
Comment 1 johnt519 2019-01-30 06:47:41 PST
Created attachment 360578 [details]
Sample of S.T.P Process when beach balled.
Comment 2 Radar WebKit Bug Importer 2019-01-30 10:22:29 PST
<rdar://problem/47671494>
Comment 3 Alexey Proskuryakov 2019-02-03 20:24:52 PST
This is believed to be fixed via bug 193779.

*** This bug has been marked as a duplicate of bug 193779 ***