Bug 193997 - After the fix for bug 192529, fast/scrolling/ios/hit-testing-iframe.html fails
Summary: After the fix for bug 192529, fast/scrolling/ios/hit-testing-iframe.html fails
Status: RESOLVED DUPLICATE of bug 195099
Alias: None
Product: WebKit
Classification: Unclassified
Component: Scrolling (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2019-01-29 17:10 PST by Simon Fraser (smfr)
Modified: 2019-02-27 09:29 PST (History)
5 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Simon Fraser (smfr) 2019-01-29 17:10:26 PST
fast/scrolling/ios/hit-testing-iframe.html is doing frame scrolling in the UI process. Sometime during the interaction with the last frame ("clickElementInsideFrameAfterUserScroll"), we get a full scrolling tree update from the web process which clobbers the scroll position back to 0,0, causing the last hit test to fail.

This suggests that iOS frame scrolls aren't getting back to the web process. It also suggests that maybe we need to be more incremental about reconnecting subframe scrolling tree nodes to avoid churn.

I'll mark the test as failing for now.
Comment 1 Frédéric Wang (:fredw) 2019-01-30 00:21:49 PST
(In reply to Simon Fraser (smfr) from comment #0)
> fast/scrolling/ios/hit-testing-iframe.html is doing frame scrolling in the
> UI process. Sometime during the interaction with the last frame
> ("clickElementInsideFrameAfterUserScroll"), we get a full scrolling tree
> update from the web process which clobbers the scroll position back to 0,0,
> causing the last hit test to fail.
> 
> This suggests that iOS frame scrolls aren't getting back to the web process.
> It also suggests that maybe we need to be more incremental about
> reconnecting subframe scrolling tree nodes to avoid churn.
> 
> I'll mark the test as failing for now.

Yes, the sync from web to UI process was supposed to be implemented in bug 182868 but the patch is no longer working with the new approach. All test cases involving programmatic scrolling are known to fail right now.
Comment 2 Radar WebKit Bug Importer 2019-01-30 10:26:27 PST
<rdar://problem/47671657>
Comment 3 Simon Fraser (smfr) 2019-02-27 09:29:23 PST
Fixed via bug 195099.

*** This bug has been marked as a duplicate of bug 195099 ***