Bug 193893 - Scrolling with background-attachment: fixed needs to trigger repaints
Summary: Scrolling with background-attachment: fixed needs to trigger repaints
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Scrolling (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Simon Fraser (smfr)
URL:
Keywords: InRadar
: 210758 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-01-27 21:06 PST by Simon Fraser (smfr)
Modified: 2020-04-20 14:55 PDT (History)
14 users (show)

See Also:


Attachments
Patch (22.03 KB, patch)
2020-04-20 12:23 PDT, Simon Fraser (smfr)
dino: review+
Details | Formatted Diff | Diff
Patch (23.46 KB, patch)
2020-04-20 13:04 PDT, Simon Fraser (smfr)
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Simon Fraser (smfr) 2019-01-27 21:06:10 PST
Need to make background-attachment: fixed in accelerated overflow:scroll either work, or kick us out of async scrolling.
Comment 1 Radar WebKit Bug Importer 2019-01-27 21:06:38 PST
<rdar://problem/47587017>
Comment 2 Simon Fraser (smfr) 2020-04-20 12:21:22 PDT
*** Bug 210758 has been marked as a duplicate of this bug. ***
Comment 3 Simon Fraser (smfr) 2020-04-20 12:23:21 PDT
Created attachment 397000 [details]
Patch
Comment 4 Dean Jackson 2020-04-20 12:27:22 PDT
Comment on attachment 397000 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=397000&action=review

> LayoutTests/scrollingcoordinator/mac/fixed-backgrounds/fixed-background-in-overflow-repaint.html:27
> +            let scroller = document.querySelector('.scroller');

Antoine would nit const you here. But to that I say: https://www.instagram.com/tv/B_FoCbNHR71/
Comment 5 Simon Fraser (smfr) 2020-04-20 13:04:51 PDT
Created attachment 397007 [details]
Patch
Comment 6 EWS 2020-04-20 14:55:42 PDT
Committed r260403: <https://trac.webkit.org/changeset/260403>

All reviewed patches have been landed. Closing bug and clearing flags on attachment 397007 [details].