Bug 193736 - [css-grid] Flaky tests from bug 193657
Summary: [css-grid] Flaky tests from bug 193657
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: CSS (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Oriol Brufau
URL:
Keywords: InRadar
Depends on:
Blocks: 193657
  Show dependency treegraph
 
Reported: 2019-01-23 12:55 PST by Oriol Brufau
Modified: 2019-01-24 08:51 PST (History)
3 users (show)

See Also:


Attachments
Patch (2.14 KB, patch)
2019-01-23 13:04 PST, Oriol Brufau
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Oriol Brufau 2019-01-23 12:55:06 PST
Bug 193657 imported various WPT tests. Some still had failures due to bug 189513 and bug 193656.
However, it seems that the exact failures are flaky, e.g.
https://build.webkit.org/results/Apple%20High%20Sierra%20Release%20WK2%20(Tests)/r240334%20(9001)/results.html
https://build.webkit.org/results/Apple%20High%20Sierra%20Release%20WK2%20(Tests)/r240333%20(9000)/results.html
This is making the tree red.
Comment 1 Oriol Brufau 2019-01-23 13:04:38 PST
Created attachment 359934 [details]
Patch
Comment 2 WebKit Commit Bot 2019-01-23 14:16:00 PST
Comment on attachment 359934 [details]
Patch

Clearing flags on attachment: 359934

Committed r240362: <https://trac.webkit.org/changeset/240362>
Comment 3 WebKit Commit Bot 2019-01-23 14:16:01 PST
All reviewed patches have been landed.  Closing bug.
Comment 4 Radar WebKit Bug Importer 2019-01-23 14:16:28 PST
<rdar://problem/47493645>
Comment 5 Oriol Brufau 2019-01-24 08:51:22 PST
Locally I can reproduce the flakiness with WPE but not with GTK.
However, if I add `body { overflow: scroll; }` to the tests, so that layout is only done once, then they seem to always pass in WPE too.