WebKit Bugzilla
New
Browse
Log In
×
Sign in with GitHub
or
Remember my login
Create Account
·
Forgot Password
Forgotten password account recovery
RESOLVED FIXED
193469
[WHLSL] Delete the 'restricted' keyword
https://bugs.webkit.org/show_bug.cgi?id=193469
Summary
[WHLSL] Delete the 'restricted' keyword
Myles C. Maxfield
Reported
2019-01-15 15:51:24 PST
[WHLSL] Delete the 'restricted' keyword
Attachments
Patch
(25.13 KB, patch)
2019-01-15 15:52 PST
,
Myles C. Maxfield
rmorisset
: review+
Details
Formatted Diff
Diff
View All
Add attachment
proposed patch, testcase, etc.
Myles C. Maxfield
Comment 1
2019-01-15 15:52:52 PST
Created
attachment 359215
[details]
Patch
Robin Morisset
Comment 2
2019-01-15 16:00:07 PST
Comment on
attachment 359215
[details]
Patch View in context:
https://bugs.webkit.org/attachment.cgi?id=359215&action=review
LGTM
> Source/WebCore/Modules/webgpu/WHLSL/WHLSLResolveOverloadImpl.cpp:74 > + if (minimumCostCandidates.size() == 1)
Maybe rename minimumCostCandidates, since I don't think there is a notion of cost anymore.
Myles C. Maxfield
Comment 3
2019-01-15 16:03:05 PST
(In reply to Robin Morisset from
comment #2
)
> Comment on
attachment 359215
[details]
> Patch > > View in context: >
https://bugs.webkit.org/attachment.cgi?id=359215&action=review
> > LGTM > > > Source/WebCore/Modules/webgpu/WHLSL/WHLSLResolveOverloadImpl.cpp:74 > > + if (minimumCostCandidates.size() == 1) > > Maybe rename minimumCostCandidates, since I don't think there is a notion of > cost anymore.
There is a notion of cost. void foo(int) { ... } void foo(uint) { ... } foo(4) resolves to a different overload than foo(4u)
Dean Jackson
Comment 4
2019-01-16 12:05:17 PST
r=me too
Myles C. Maxfield
Comment 5
2019-01-16 16:59:22 PST
Committed
r240097
: <
https://trac.webkit.org/changeset/240097
>
Radar WebKit Bug Importer
Comment 6
2019-01-16 17:00:29 PST
<
rdar://problem/47335266
>
Note
You need to
log in
before you can comment on or make changes to this bug.
Top of Page
Format For Printing
XML
Clone This Bug