Bug 19315 - Table cell background image inherited incorrectly
Summary: Table cell background image inherited incorrectly
Status: RESOLVED DUPLICATE of bug 9268
Alias: None
Product: WebKit
Classification: Unclassified
Component: CSS (show other bugs)
Version: 525.x (Safari 3.1)
Hardware: Macintosh OS X 10.5
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-05-29 17:04 PDT by chendo
Modified: 2009-12-02 19:37 PST (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description chendo 2008-05-29 17:04:48 PDT
When applying a background style to a <tr> tag, all the cells within that <tr> tag inherits the background tag, causing the background image to be applied more than once.

This renders fine in FF3b6, haven't checked other browsers yet.

Reproducible code is below:

<html>
<head>
  <title>WebKit CSS bug</title>
  <style type="text/css">
  <!--
  tr
  {
    background: url(http://www.google.com/images/nav_logo3.png) no-repeat;
  }
  
  th, td
  {
    width: 200px;
    height: 100px;
  }
  -->
  </style>
</head>
<body>
  <table>
    <tr>
      <th>blah</th>
      <th>blah</th>
      <th>blah</th>
      <td>blah</td>
      <td>blah</td>
    </tr>
  </table>
</body>
</html>
Comment 1 Dave Hyatt 2008-05-29 18:04:10 PDT
We match IE"s rendering here I believe.
Comment 2 chendo 2008-05-29 18:22:06 PDT
(In reply to comment #1)
> We match IE"s rendering here I believe.
> 

Wait, that is supposed to be a GOOD thing?

I'm pretty sure IE's rendering engine isn't something that other engines should try to match.
Comment 3 Bodaniel Jeanes 2008-05-29 18:23:13 PDT
(In reply to comment #1)
> We match IE"s rendering here I believe.
> 

yeah the funny thing is here .... why!?? Usually if IE does it a certain way ... you know it's probably wrong.
Comment 4 Daniel Bates 2009-12-02 19:37:23 PST

*** This bug has been marked as a duplicate of bug 9268 ***