Bug 192936 - [iOS] Replace "node assistance" terminology in WebKit with "focused element"
Summary: [iOS] Replace "node assistance" terminology in WebKit with "focused element"
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit2 (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Wenson Hsieh
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2018-12-20 09:08 PST by Wenson Hsieh
Modified: 2018-12-20 10:43 PST (History)
9 users (show)

See Also:


Attachments
Patch (199.63 KB, patch)
2018-12-20 09:40 PST, Wenson Hsieh
no flags Details | Formatted Diff | Diff
Update a Copyright year (199.64 KB, patch)
2018-12-20 09:42 PST, Wenson Hsieh
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Wenson Hsieh 2018-12-20 09:08:59 PST
We use "node assistance" terminology in many places in WebKit to mean "focused element", but this is strange and confusing to anyone new to this code (e.g. the StartAssistingNode/StopAssistingNode IPC messages). WebPage also has methods like "elementDidFocus" and "elementDidBlur" that currently take Node*, but should really take Element&.
Comment 1 Wenson Hsieh 2018-12-20 09:40:01 PST
Created attachment 357819 [details]
Patch
Comment 2 Wenson Hsieh 2018-12-20 09:42:37 PST
Created attachment 357820 [details]
Update a Copyright year
Comment 3 EWS Watchlist 2018-12-20 09:47:27 PST
Attachment 357820 [details] did not pass style-queue:


ERROR: Source/WebKit/Shared/FocusedElementInformation.h:48:  enum members should use InterCaps with an initial capital letter or initial 'k' for C-style enums.  [readability/enum_casing] [4]
Total errors found: 1 in 32 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 4 Wenson Hsieh 2018-12-20 09:50:30 PST
(In reply to Build Bot from comment #3)
> Attachment 357820 [details] did not pass style-queue:
> 
> 
> ERROR: Source/WebKit/Shared/FocusedElementInformation.h:48:  enum members
> should use InterCaps with an initial capital letter or initial 'k' for
> C-style enums.  [readability/enum_casing] [4]
> Total errors found: 1 in 32 files
> 
> 
> If any of these errors are false positives, please file a bug against
> check-webkit-style.

I feel like there should be an exception to this rule for certain acronyms (in this case, URL). I think InputType::URL certainly reads more cleanly than InputType::UniformResourceLocator.
Comment 5 Tim Horton 2018-12-20 10:26:04 PST
(In reply to Wenson Hsieh from comment #4)
> (In reply to Build Bot from comment #3)
> > Attachment 357820 [details] did not pass style-queue:
> > 
> > 
> > ERROR: Source/WebKit/Shared/FocusedElementInformation.h:48:  enum members
> > should use InterCaps with an initial capital letter or initial 'k' for
> > C-style enums.  [readability/enum_casing] [4]
> > Total errors found: 1 in 32 files
> > 
> > 
> > If any of these errors are false positives, please file a bug against
> > check-webkit-style.
> 
> I feel like there should be an exception to this rule for certain acronyms
> (in this case, URL). I think InputType::URL certainly reads more cleanly
> than InputType::UniformResourceLocator.

Agreed, so ignore it.
Comment 6 Tim Horton 2018-12-20 10:27:11 PST
Comment on attachment 357820 [details]
Update a Copyright year

rs=me (but strongly agree with the name change)
Comment 7 WebKit Commit Bot 2018-12-20 10:42:53 PST
Comment on attachment 357820 [details]
Update a Copyright year

Clearing flags on attachment: 357820

Committed r239454: <https://trac.webkit.org/changeset/239454>
Comment 8 WebKit Commit Bot 2018-12-20 10:42:55 PST
All reviewed patches have been landed.  Closing bug.
Comment 9 Radar WebKit Bug Importer 2018-12-20 10:43:35 PST
<rdar://problem/46876214>