Bug 192785 - Calling setValue() while typing should invoke -textDidChangeInTextField in the injected bundle
Summary: Calling setValue() while typing should invoke -textDidChangeInTextField in th...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Forms (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Wenson Hsieh
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2018-12-17 16:21 PST by Wenson Hsieh
Modified: 2018-12-18 16:17 PST (History)
9 users (show)

See Also:


Attachments
Patch (8.42 KB, patch)
2018-12-17 16:30 PST, Wenson Hsieh
no flags Details | Formatted Diff | Diff
Patch (8.38 KB, patch)
2018-12-17 22:26 PST, Wenson Hsieh
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Wenson Hsieh 2018-12-17 16:21:48 PST
<rdar://problem/45321184>
Comment 1 Wenson Hsieh 2018-12-17 16:30:39 PST
Created attachment 357497 [details]
Patch
Comment 2 Wenson Hsieh 2018-12-17 22:26:12 PST
Created attachment 357537 [details]
Patch
Comment 3 WebKit Commit Bot 2018-12-18 07:37:18 PST
Comment on attachment 357537 [details]
Patch

Clearing flags on attachment: 357537

Committed r239337: <https://trac.webkit.org/changeset/239337>
Comment 4 WebKit Commit Bot 2018-12-18 07:37:19 PST
All reviewed patches have been landed.  Closing bug.
Comment 5 Truitt Savell 2018-12-18 15:07:03 PST
Looks like revision https://trac.webkit.org/changeset/239337/webkit 

is causing fast/forms/datalist/datalist-textinput-suggestions-order.html

to crash intermittently. 

History:
https://webkit-test-results.webkit.org/dashboards/flakiness_dashboard.html#showAllRuns=true&tests=fast%2Fforms%2Fdatalist%2Fdatalist-textinput-suggestions-order.html 

I was able to reproduce this crash with:
run-webkit-tests --root testbuild-239337 fast/forms/datalist/datalist-textinput-suggestions-order.html --iterations 500 -f 

The crash happens on r239337 but not on r239336

Crash Log:
https://build.webkit.org/results/Apple%20Mojave%20Release%20WK2%20(Tests)/r239349%20(1465)/fast/forms/datalist/datalist-textinput-suggestions-order-crash-log.txt
Comment 6 Wenson Hsieh 2018-12-18 15:08:15 PST
(In reply to Truitt Savell from comment #5)
> Looks like revision https://trac.webkit.org/changeset/239337/webkit 
> 
> is causing fast/forms/datalist/datalist-textinput-suggestions-order.html
> 
> to crash intermittently. 
> 
> History:
> https://webkit-test-results.webkit.org/dashboards/flakiness_dashboard.
> html#showAllRuns=true&tests=fast%2Fforms%2Fdatalist%2Fdatalist-textinput-
> suggestions-order.html 
> 
> I was able to reproduce this crash with:
> run-webkit-tests --root testbuild-239337
> fast/forms/datalist/datalist-textinput-suggestions-order.html --iterations
> 500 -f 
> 
> The crash happens on r239337 but not on r239336
> 
> Crash Log:
> https://build.webkit.org/results/Apple%20Mojave%20Release%20WK2%20(Tests)/
> r239349%20(1465)/fast/forms/datalist/datalist-textinput-suggestions-order-
> crash-log.txt

Interesting! Taking a look now.
Comment 7 Truitt Savell 2018-12-18 16:04:53 PST
This test is affected too fast/forms/datalist/datalist-textinput-keydown.html

Hsitory:
https://webkit-test-results.webkit.org/dashboards/flakiness_dashboard.html#showAllRuns=true&tests=fast%2Fforms%2Fdatalist%2Fdatalist-textinput-keydown.html

same repro steps work
Comment 8 Wenson Hsieh 2018-12-18 16:17:16 PST
(In reply to Truitt Savell from comment #7)
> This test is affected too fast/forms/datalist/datalist-textinput-keydown.html
> 
> Hsitory:
> https://webkit-test-results.webkit.org/dashboards/flakiness_dashboard.
> html#showAllRuns=true&tests=fast%2Fforms%2Fdatalist%2Fdatalist-textinput-
> keydown.html
> 
> same repro steps work

Looks to be the same root cause — I'll fix both in https://bugs.webkit.org/show_bug.cgi?id=192836.