Bug 192780 - Don't use more expensive layer backing store formats when subpixel text antialiasing is not enabled
Summary: Don't use more expensive layer backing store formats when subpixel text antia...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Simon Fraser (smfr)
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2018-12-17 15:31 PST by Simon Fraser (smfr)
Modified: 2018-12-18 09:12 PST (History)
7 users (show)

See Also:


Attachments
Patch (26.95 KB, patch)
2018-12-17 15:35 PST, Simon Fraser (smfr)
thorton: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Simon Fraser (smfr) 2018-12-17 15:31:39 PST
Don't use more expensive layer backing store formats when subpixel text antialiasing is not enabled
Comment 1 Simon Fraser (smfr) 2018-12-17 15:35:51 PST
Created attachment 357485 [details]
Patch
Comment 2 Simon Fraser (smfr) 2018-12-17 15:35:53 PST
<rdar://problem/43394387>
Comment 3 Build Bot 2018-12-17 15:38:55 PST
Attachment 357485 [details] did not pass style-queue:


ERROR: Source/WebCore/platform/graphics/cocoa/FontCascadeCocoa.mm:66:  Misplaced OS version check. Please use a named macro in wtf/Platform.h or wtf/FeatureDefines.h.  [build/version_check] [5]
ERROR: Source/WebCore/PAL/pal/spi/cg/CoreGraphicsSPI.h:289:  Misplaced OS version check. Please use a named macro in wtf/Platform.h or wtf/FeatureDefines.h.  [build/version_check] [5]
Total errors found: 2 in 17 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 4 Simon Fraser (smfr) 2018-12-17 17:51:34 PST
https://trac.webkit.org/changeset/239306/webkit
Comment 5 Truitt Savell 2018-12-18 08:39:14 PST
Looks like this revision https://trac.webkit.org/changeset/239306/webkit

has caused compositing/contents-format/subpixel-antialiased-text-enabled.html

to fail constantly on Mojave wk1. 

I was able to reproduce with:

run-webkit-tests --root testbuild-239306 compositing/contents-format/subpixel-antialiased-text-enabled.html --iterations 50 -f -1

the test fails constantly on r239306 but passes when ran on 239305.


Diff:
--- /Volumes/Data/slave/mojave-debug-tests-wk1/build/layout-test-results/compositing/contents-format/subpixel-antialiased-text-enabled-expected.txt
+++ /Volumes/Data/slave/mojave-debug-tests-wk1/build/layout-test-results/compositing/contents-format/subpixel-antialiased-text-enabled-actual.txt
@@ -8,10 +8,6 @@
     (GraphicsLayer
       (bounds 5018.00 2018.00)
       (contentsOpaque 1)
-      (tile cache coverage 0, 0 1024 x 1024)
-      (tile size 512 x 512)
-      (top left tile 0, 0 tiles grid 2 x 2)
-      (in window 1)
       (children 3
         (GraphicsLayer
           (position 18.00 10.00)
Comment 6 Simon Fraser (smfr) 2018-12-18 08:42:55 PST
Why was EWS green? I'll fix, please don't roll out.
Comment 8 Simon Fraser (smfr) 2018-12-18 09:10:42 PST
We need more EWS
Comment 9 Simon Fraser (smfr) 2018-12-18 09:12:09 PST
Committing to http://svn.webkit.org/repository/webkit/trunk ...
	A	LayoutTests/platform/mac-mojave-wk1/compositing/contents-format/subpixel-antialiased-text-enabled-expected.txt
	M	LayoutTests/ChangeLog
Committed r239338