Bug 192722 - [WebAuthN] Support Attestation Conveyance Preference
Summary: [WebAuthN] Support Attestation Conveyance Preference
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebCore Misc. (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Jiewen Tan
URL:
Keywords: InRadar
: 196969 (view as bug list)
Depends on:
Blocks: 181943
  Show dependency treegraph
 
Reported: 2018-12-14 16:14 PST by Jiewen Tan
Modified: 2019-05-22 12:28 PDT (History)
7 users (show)

See Also:


Attachments
Patch (58.53 KB, patch)
2019-05-22 02:06 PDT, Jiewen Tan
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jiewen Tan 2018-12-14 16:14:58 PST
Support Attestation Conveyance Preference: https://www.w3.org/TR/webauthn/#attestation-convey.
Comment 1 Jiewen Tan 2019-04-18 13:33:00 PDT
*** Bug 196969 has been marked as a duplicate of this bug. ***
Comment 2 Jiewen Tan 2019-05-22 01:51:31 PDT
<rdar://problem/49939647>
Comment 3 Jiewen Tan 2019-05-22 02:06:20 PDT
Created attachment 370389 [details]
Patch
Comment 4 Build Bot 2019-05-22 02:08:25 PDT
Attachment 370389 [details] did not pass style-queue:


ERROR: Source/WebCore/Modules/webauthn/fido/DeviceResponseConverter.h:52:  The parameter name "attestation" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: Source/WebCore/Modules/webauthn/fido/U2fResponseConverter.h:42:  The parameter name "attestation" adds no information, so it should be removed.  [readability/parameter_name] [5]
Total errors found: 2 in 32 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 5 Brent Fulgham 2019-05-22 08:02:27 PDT
Comment on attachment 370389 [details]
Patch

R= me
Comment 6 Jiewen Tan 2019-05-22 11:56:32 PDT
(In reply to Brent Fulgham from comment #5)
> Comment on attachment 370389 [details]
> Patch
> 
> R= me

Thanks Brent for r+ this patch.
Comment 7 WebKit Commit Bot 2019-05-22 12:27:55 PDT
Comment on attachment 370389 [details]
Patch

Clearing flags on attachment: 370389

Committed r245638: <https://trac.webkit.org/changeset/245638>
Comment 8 WebKit Commit Bot 2019-05-22 12:27:57 PDT
All reviewed patches have been landed.  Closing bug.
Comment 9 Radar WebKit Bug Importer 2019-05-22 12:28:18 PDT Comment hidden (obsolete)