Bug 19272 - Clean up NAN in JavaScriptCore?
Summary: Clean up NAN in JavaScriptCore?
Status: RESOLVED DUPLICATE of bug 16777
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.5
: P3 Minor
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-05-27 11:51 PDT by Darin Adler
Modified: 2011-06-10 18:25 PDT (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Darin Adler 2008-05-27 11:51:16 PDT
JavaScriptCore uses the following redundant ways to get the double NAN:

    function std::numeric_limits<double>::quiet_NaN()
    global KJS::NaN
    macro NAN

There's also code that says (isnan || isinf) where it could more efficiently say !isfinite instead. We should clean this up. I'd like to see KJS::NaN and KJS::Inf go away entirely.
Comment 1 Gavin Barraclough 2011-06-10 18:25:28 PDT

*** This bug has been marked as a duplicate of bug 16777 ***