Bug 192445 - Web Inspector: REGRESSION: Instances/Object Graph doesn't stay selected when switching back/forth in Timelines
Summary: Web Inspector: REGRESSION: Instances/Object Graph doesn't stay selected when ...
Status: RESOLVED DUPLICATE of bug 192451
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (show other bugs)
Version: WebKit Nightly Build
Hardware: All All
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-12-05 19:02 PST by Devin Rousso
Modified: 2018-12-05 20:38 PST (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Devin Rousso 2018-12-05 19:02:54 PST
* STEPS TO REPRODUCE:
1. inspect any page
2. go to Timelines
3. enable the "JavaScript Allocations" timeline
4. take a recording
5. select a heap snapshot
6. switch from "Instances" to "Object Graph"
7. Go to a different tab
8. Go back to Timelines
 => "Instances" is selected
Comment 1 Devin Rousso 2018-12-05 19:03:41 PST
This is also true for switching from "Object Graph" to "Instances".  It seems like whatever was selected when it was shown for the first time is the setting that is used.
Comment 2 Devin Rousso 2018-12-05 20:38:08 PST

*** This bug has been marked as a duplicate of bug 192451 ***