Bug 192307 - REGRESSION(r238583): [WPE] Image flickering in Youtube TV
Summary: REGRESSION(r238583): [WPE] Image flickering in Youtube TV
Status: RESOLVED DUPLICATE of bug 192597
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Zan Dobersek
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-12-03 04:04 PST by Carlos Eduardo Ramalho
Modified: 2018-12-14 17:52 PST (History)
6 users (show)

See Also:


Attachments
WPE Youtube TV (271.30 KB, video/webm)
2018-12-03 04:04 PST, Carlos Eduardo Ramalho
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Carlos Eduardo Ramalho 2018-12-03 04:04:47 PST
Created attachment 356373 [details]
WPE Youtube TV

Using the Youtube TV with WPE in r238737 causes some images to flick while navigating the UI (see attached screencast).

Cannot reproduce this with WebKitGTK+ 2.22.4 and WEBKIT_FORCE_COMPOSITING_MODE=1.

Tested with WPE's MiniBrowser in gnome-shell on wayland and weston.
Comment 1 Carlos Eduardo Ramalho 2018-12-05 18:31:50 PST
Flickering doesn't happen before https://trac.webkit.org/r238583

Found it through git-bisect.
Comment 2 Simon Fraser (smfr) 2018-12-05 19:00:03 PST
Sorry for this regression. It suggests that WPE is doing something differently with compositing, but I don't know what that is.

From the video it looks like that kind of content would be composited all the time, so it shouldn't fall into the "only compositing layer is the root" code path.
Comment 3 Zan Dobersek 2018-12-08 10:06:38 PST
*** Bug 192276 has been marked as a duplicate of this bug. ***
Comment 4 Miguel Gomez 2018-12-11 05:12:27 PST
(In reply to Simon Fraser (smfr) from comment #2)
> Sorry for this regression. It suggests that WPE is doing something
> differently with compositing, but I don't know what that is.
> 
> From the video it looks like that kind of content would be composited all
> the time, so it shouldn't fall into the "only compositing layer is the root"
> code path.

I could not look into it carefully, but I think the content is just composited during the animations. Once the animations are finished (and before they begin) the root layer is the only one that's composited.
Comment 5 Simon Fraser (smfr) 2018-12-11 10:38:59 PST
Possibly the same as bug 192597?
Comment 6 Carlos Eduardo Ramalho 2018-12-14 17:52:49 PST
(In reply to Simon Fraser (smfr) from comment #5)
> Possibly the same as bug 192597?

It is indeed. Just tested before/after r239146 and you fixed the problem for here too.

Thanks a lot! :)

*** This bug has been marked as a duplicate of bug 192597 ***