Extracting the windowToContents/contentToWindow changes from bug 173833. These are necessary to properly handle hit testing.
Created attachment 356365 [details] Patch (applies on top of bug 173833) This has been extracted from attachment 356214 [details]
Comment on attachment 356365 [details] Patch (applies on top of bug 173833) View in context: https://bugs.webkit.org/attachment.cgi?id=356365&action=review > Source/WebCore/page/FrameView.h:682 > + bool coordinateChangeShouldIgnoreScrollPosition() const final; Please rename this to windowToContentsShouldIgnoreScrollPosition()
Comment on attachment 356365 [details] Patch (applies on top of bug 173833) View in context: https://bugs.webkit.org/attachment.cgi?id=356365&action=review >> Source/WebCore/page/FrameView.h:682 >> + bool coordinateChangeShouldIgnoreScrollPosition() const final; > > Please rename this to windowToContentsShouldIgnoreScrollPosition() smfr: I can but note that as I said elsewhere the function might be needed in other siutations: https://bugs.webkit.org/attachment.cgi?id=353085&action=review https://bugs.webkit.org/attachment.cgi?id=348915&action=review Anyway, this is blocked by bug 173833.
Comment on attachment 356365 [details] Patch (applies on top of bug 173833) View in context: https://bugs.webkit.org/attachment.cgi?id=356365&action=review Want to land this? > Source/WebCore/platform/ScrollView.cpp:933 > - if (delegatesScrolling()) > + if (coordinateChangeShouldIgnoreScrollPosition()) This change is needed in a bunch of other places too (IntRect, rootView versions versions of these function).
Comment on attachment 356365 [details] Patch (applies on top of bug 173833) View in context: https://bugs.webkit.org/attachment.cgi?id=356365&action=review @Antti: Feel free to land the code changes if you want to. >> Source/WebCore/platform/ScrollView.cpp:933 >> + if (coordinateChangeShouldIgnoreScrollPosition()) > > This change is needed in a bunch of other places too (IntRect, rootView versions versions of these function). Yes, but I tried to keep this minimal and focused as Simon had concerned about changing all these functions. See also comment 3 for similar bugs (involving other functions).
Actually I think this is wrong. The delegatesScrolling bit shouldn't be set for subframes in the first place. It is meant for application controlled top level scrolling only.
Created attachment 359686 [details] patch
Comment on attachment 359686 [details] patch Clearing flags on attachment: 359686 Committed r240249: <https://trac.webkit.org/changeset/240249>
All reviewed patches have been landed. Closing bug.
<rdar://problem/47438192>
> 15:29:48 - anttik: fredw: note that the test is missing the programmatic scroll subtest, that needs an additional fix > 15:30:46 - fredw: anttik: ok. Yes I guess we need the stuff from bug 182868 for programmatic scrolling Will move the remaining test into bug 182868.
*** Bug 197613 has been marked as a duplicate of this bug. ***