Bug 192260 - webkitpy: Support unicode in MeteredStream
Summary: webkitpy: Support unicode in MeteredStream
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Jonathan Bedard
URL:
Keywords: InRadar
: 188718 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-11-30 15:16 PST by Jonathan Bedard
Modified: 2018-12-04 11:00 PST (History)
9 users (show)

See Also:


Attachments
Patch (2.41 KB, patch)
2018-11-30 15:21 PST, Jonathan Bedard
no flags Details | Formatted Diff | Diff
Archive of layout-test-results from ews100 for mac-sierra (2.78 MB, application/zip)
2018-11-30 16:03 PST, Build Bot
no flags Details
Patch (2.83 KB, patch)
2018-12-03 13:21 PST, Jonathan Bedard
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Bedard 2018-11-30 15:16:50 PST
We should support unicode in the MeteredStream object since it's possible for test diffs to contain unicode.
Comment 1 Jonathan Bedard 2018-11-30 15:21:34 PST
Created attachment 356246 [details]
Patch
Comment 2 Build Bot 2018-11-30 16:03:20 PST
Comment on attachment 356246 [details]
Patch

Attachment 356246 [details] did not pass mac-ews (mac):
Output: https://webkit-queues.webkit.org/results/10221118

New failing tests:
workers/bomb.html
Comment 3 Build Bot 2018-11-30 16:03:22 PST
Created attachment 356255 [details]
Archive of layout-test-results from ews100 for mac-sierra

The attached test failures were seen while running run-webkit-tests on the mac-ews.
Bot: ews100  Port: mac-sierra  Platform: Mac OS X 10.12.6
Comment 4 Jonathan Bedard 2018-11-30 16:17:29 PST
workers/bomb.html is a flakey test.
Comment 5 Jonathan Bedard 2018-11-30 16:19:56 PST
*** Bug 188718 has been marked as a duplicate of this bug. ***
Comment 6 WebKit Commit Bot 2018-11-30 16:32:49 PST
Comment on attachment 356246 [details]
Patch

Clearing flags on attachment: 356246

Committed r238764: <https://trac.webkit.org/changeset/238764>
Comment 7 WebKit Commit Bot 2018-11-30 16:32:51 PST
All reviewed patches have been landed.  Closing bug.
Comment 8 Radar WebKit Bug Importer 2018-11-30 16:33:40 PST
<rdar://problem/46388376>
Comment 9 Jonathan Bedard 2018-12-01 13:09:10 PST
Reverted r238764 for reason:

Breaks existing layout tests

Committed r238784: <https://trac.webkit.org/changeset/238784>
Comment 10 Jonathan Bedard 2018-12-03 13:21:07 PST
Created attachment 356400 [details]
Patch
Comment 11 WebKit Commit Bot 2018-12-04 11:00:34 PST
Comment on attachment 356400 [details]
Patch

Clearing flags on attachment: 356400

Committed r238862: <https://trac.webkit.org/changeset/238862>
Comment 12 WebKit Commit Bot 2018-12-04 11:00:35 PST
All reviewed patches have been landed.  Closing bug.