Bug 192109 - Web Inspector: Styles: enable selection of multiple properties by default
Summary: Web Inspector: Styles: enable selection of multiple properties by default
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (show other bugs)
Version: WebKit Nightly Build
Hardware: All All
: P2 Normal
Assignee: Nikita Vasilyev
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2018-11-28 15:16 PST by Nikita Vasilyev
Modified: 2018-11-28 17:11 PST (History)
4 users (show)

See Also:


Attachments
Patch (11.50 KB, patch)
2018-11-28 15:41 PST, Nikita Vasilyev
drousso: review+
Details | Formatted Diff | Diff
Patch (11.53 KB, patch)
2018-11-28 16:22 PST, Nikita Vasilyev
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Nikita Vasilyev 2018-11-28 15:16:12 PST
Keep the feature enabled and remove the experimental setting.
Comment 1 Radar WebKit Bug Importer 2018-11-28 15:16:54 PST
<rdar://problem/46323565>
Comment 2 Nikita Vasilyev 2018-11-28 15:41:38 PST
Created attachment 355937 [details]
Patch
Comment 3 Devin Rousso 2018-11-28 16:11:54 PST
Comment on attachment 355937 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=355937&action=review

r=me

> Source/WebInspectorUI/UserInterface/Views/SpreadsheetCSSStyleDeclarationEditor.css:53
> +.spreadsheet-style-declaration-editor :matches(.name, .value):not(.editing) {

Is this rule actually needed?  Can we remove it?

> Source/WebInspectorUI/UserInterface/Views/SpreadsheetCSSStyleDeclarationEditor.css:64
> +.spreadsheet-style-declaration-editor :matches(.name, .value):not(.editing) {

This rule is a duplicate of (53), so please remove it.
Comment 4 Nikita Vasilyev 2018-11-28 16:16:55 PST
Comment on attachment 355937 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=355937&action=review

>> Source/WebInspectorUI/UserInterface/Views/SpreadsheetCSSStyleDeclarationEditor.css:53
>> +.spreadsheet-style-declaration-editor :matches(.name, .value):not(.editing) {
> 
> Is this rule actually needed?  Can we remove it?

It's still needed. Start editing name or value, focus another window, and then focus Web Inspector again.

>> Source/WebInspectorUI/UserInterface/Views/SpreadsheetCSSStyleDeclarationEditor.css:64
>> +.spreadsheet-style-declaration-editor :matches(.name, .value):not(.editing) {
> 
> This rule is a duplicate of (53), so please remove it.

Huh, must have been from a bad merge before.
Comment 5 Nikita Vasilyev 2018-11-28 16:22:31 PST
Created attachment 355941 [details]
Patch
Comment 6 WebKit Commit Bot 2018-11-28 17:10:33 PST
The commit-queue encountered the following flaky tests while processing attachment 355941 [details]:

webgl/1.0.2/conformance/more/functions/copyTexImage2D.html bug 192125 (author: roger_fong@apple.com)
The commit-queue is continuing to process your patch.
Comment 7 WebKit Commit Bot 2018-11-28 17:11:21 PST
Comment on attachment 355941 [details]
Patch

Clearing flags on attachment: 355941

Committed r238649: <https://trac.webkit.org/changeset/238649>
Comment 8 WebKit Commit Bot 2018-11-28 17:11:23 PST
All reviewed patches have been landed.  Closing bug.