Bug 191935 - [ews-app] Add support to communicate with Buildbot
Summary: [ews-app] Add support to communicate with Buildbot
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: Other
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Aakash Jain
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2018-11-23 17:57 PST by Aakash Jain
Modified: 2018-11-26 17:10 PST (History)
5 users (show)

See Also:


Attachments
Proposed patch (4.00 KB, patch)
2018-11-23 19:06 PST, Aakash Jain
lforschler: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Aakash Jain 2018-11-23 17:57:32 PST
ews-app needs to send patches to Buildbot using 'buildbot try' command. We should add that feature.
Comment 1 Aakash Jain 2018-11-23 19:06:20 PST
Created attachment 355550 [details]
Proposed patch

Part of patch series. Therefore wouldn't apply to ToT without applying other patches first.
Comment 2 Lucas Forschler 2018-11-26 12:51:04 PST
Comment on attachment 355550 [details]
Proposed patch

View in context: https://bugs.webkit.org/attachment.cgi?id=355550&action=review

> Tools/BuildSlaveSupport/ews-app/ews/common/buildbot.py:44
> +            _log.warn('Error in executing: {}, rc={}'.format(command, return_code))

This should be:
Error executing:
or
Error while executing:
Comment 3 Kocsen Chung 2018-11-26 14:59:56 PST
Comment on attachment 355550 [details]
Proposed patch

View in context: https://bugs.webkit.org/attachment.cgi?id=355550&action=review

> Tools/BuildSlaveSupport/ews-app/ews/common/buildbot.py:35
> +        command = ['buildbot', 'try', '--connect=pb', '--master={}:{}'.format(config.BUG_SERVER_HOST, config.BUILDBOT_SERVER_PORT),

nit:
Have every `--flag [param]` pair be in it's own new line for readability.

>> Tools/BuildSlaveSupport/ews-app/ews/common/buildbot.py:44
>> +            _log.warn('Error in executing: {}, rc={}'.format(command, return_code))
> 
> This should be:
> Error executing:
> or
> Error while executing:

nit: spell out `rc` => `return code` and have it be on a new line.
Comment 4 Aakash Jain 2018-11-26 17:08:26 PST
> nit:
> Have every `--flag [param]` pair be in it's own new line for readability.
Sure.

> nit: spell out `rc` => `return code`
Done

> and have it be on a new line.
Tried with and without new line, having on same line seems more readable.

> > This should be:
> > Error executing:
Changed.
Comment 5 Aakash Jain 2018-11-26 17:09:21 PST
Committed r238535: <http://trac.webkit.org/changeset/238535>
Comment 6 Radar WebKit Bug Importer 2018-11-26 17:10:59 PST
<rdar://problem/46262314>