Bug 191808 - Rename RenderLayerCompositor::inCompositingMode() to usesCompositing()
Summary: Rename RenderLayerCompositor::inCompositingMode() to usesCompositing()
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Simon Fraser (smfr)
Keywords: InRadar
Depends on:
Reported: 2018-11-17 11:07 PST by Simon Fraser (smfr)
Modified: 2018-11-17 16:53 PST (History)
3 users (show)

See Also:

Patch (14.38 KB, patch)
2018-11-17 11:07 PST, Simon Fraser (smfr)
zalan: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Simon Fraser (smfr) 2018-11-17 11:07:13 PST
Rename RenderLayerCompositor::inCompositingMode() to usesCompositing()
Comment 1 Simon Fraser (smfr) 2018-11-17 11:07:56 PST
Created attachment 355196 [details]
Comment 2 zalan 2018-11-17 11:44:42 PST
Comment on attachment 355196 [details]

View in context: https://bugs.webkit.org/attachment.cgi?id=355196&action=review

> Source/WebCore/page/FrameView.cpp:2412
>          clearBackingStores();

I'd go even one step further and move clearBackingStore() into a lambda since no one else calls into it (it's public on FrameView!) and then you could even drop some lines from clearBackingStores (assert and the renderView() check)
Comment 3 Simon Fraser (smfr) 2018-11-17 16:52:09 PST
Comment 4 Radar WebKit Bug Importer 2018-11-17 16:53:25 PST