Bug 19174 - Double quotes do not stick to question marks when wrapping
Summary: Double quotes do not stick to question marks when wrapping
Status: RESOLVED DUPLICATE of bug 17475
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.5
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-05-21 15:41 PDT by Marc Prud'hommeaux
Modified: 2008-05-21 18:13 PDT (History)
1 user (show)

See Also:


Attachments
HTML file showing quotes not sticking to question marks when wrapping (1.72 KB, text/html)
2008-05-21 15:42 PDT, Marc Prud'hommeaux
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marc Prud'hommeaux 2008-05-21 15:41:04 PDT
When a double-quote is next to a question mark at a line break point, then the double-quote can separate from the question mark when wrapping. This is especially noticeable when reading dialog in narrow, frequently wrapped columns.

For example, the string "Hello?" could be wrapped so that "Hello? appears on one line, and then a stray " appears at the beginning of the next line. I.e., it turns into:

"Hello?
"

I've attached an HTML file that demonstrates this behavior, provided you resize the browser window until you see the wrap. For comparison, Mozilla always keeps the quotes attached to the question mark. Also, note that this only seems to be a problem with question marks: periods next to quotation marks are never separated when rendered with webkit, nor are exclamation points.
Comment 1 Marc Prud'hommeaux 2008-05-21 15:42:06 PDT
Created attachment 21278 [details]
HTML file showing quotes not sticking to question marks when wrapping
Comment 2 mitz 2008-05-21 18:13:44 PDT
Marking as a duplicate of bug 17475. I will add a note there about the double quotation mark case.

*** This bug has been marked as a duplicate of 17475 ***