Bug 19153 - Inspector should support console.debug
: Inspector should support console.debug
Status: RESOLVED FIXED
Product: WebKit
Classification: Unclassified
Component: Web Inspector (Deprecated)
: 528+ (Nightly build)
: All All
: P2 Enhancement
Assigned To: Adam Roben (:aroben)
: InRadar
Depends on:
Blocks: 14354
  Show dependency treegraph
 
Reported: 2008-05-20 16:14 PDT by Adam Roben (:aroben)
Modified: 2011-03-10 11:53 PST (History)
1 user (show)

See Also:


Attachments
patch v1 + ChangeLog (3.62 KB, patch)
2008-05-20 17:58 PDT, Adam Roben (:aroben)
sam: review-
Details | Formatted Diff | Diff
patch v2 + ChangeLog (5.12 KB, patch)
2008-05-21 09:20 PDT, Adam Roben (:aroben)
timothy: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Adam Roben (:aroben) 2008-05-20 16:14:10 PDT
The Inspector should support console.debug for Firebug parity.
Comment 1 Adam Roben (:aroben) 2008-05-20 16:22:50 PDT
*** Bug 19154 has been marked as a duplicate of this bug. ***
Comment 2 Mark Rowe (bdash) 2008-05-20 16:22:59 PDT
<rdar://problem/5950856>
Comment 3 Adam Roben (:aroben) 2008-05-20 17:58:44 PDT
Created attachment 21265 [details]
patch v1 + ChangeLog
Comment 4 Sam Weinig 2008-05-20 18:20:06 PDT
Comment on attachment 21265 [details]
patch v1 + ChangeLog

The aliasing should be done in Console, not JSConsole.  The JS wrapper is supposed to be a thin wrapper that knows as little as possible about the implementation.
Comment 5 Adam Roben (:aroben) 2008-05-21 09:20:00 PDT
Created attachment 21268 [details]
patch v2 + ChangeLog

Addresses Sam's comments
Comment 6 Adam Roben (:aroben) 2008-05-21 22:59:49 PDT
Committed in r34010
Comment 7 Alex Yaroshevich 2011-03-10 11:53:02 PST
DevTools in Chrome have console-debug-level style class, but console.debug creates div with console-log-level.
console.info method exists but also with class console-log-level.
They're really different messages. Why they creates with the same class?