Bug 191415 - U+180E is no longer a whitespace character
Summary: U+180E is no longer a whitespace character
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Ross Kirsling
URL:
Keywords: InRadar
: 126608 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-11-07 21:48 PST by Ross Kirsling
Modified: 2018-11-08 15:41 PST (History)
10 users (show)

See Also:


Attachments
Patch (15.41 KB, patch)
2018-11-07 22:59 PST, Ross Kirsling
no flags Details | Formatted Diff | Diff
Patch (20.97 KB, patch)
2018-11-07 23:54 PST, Ross Kirsling
no flags Details | Formatted Diff | Diff
Archive of layout-test-results from ews100 for mac-sierra (2.48 MB, application/zip)
2018-11-08 01:09 PST, Build Bot
no flags Details
Archive of layout-test-results from ews104 for mac-sierra-wk2 (3.12 MB, application/zip)
2018-11-08 01:17 PST, Build Bot
no flags Details
Archive of layout-test-results from ews121 for ios-simulator-wk2 (2.51 MB, application/zip)
2018-11-08 01:50 PST, Build Bot
no flags Details
Archive of layout-test-results from ews202 for win-future (12.86 MB, application/zip)
2018-11-08 01:54 PST, Build Bot
no flags Details
Archive of layout-test-results from ews114 for mac-sierra (3.39 MB, application/zip)
2018-11-08 02:00 PST, Build Bot
no flags Details
Archive of layout-test-results from ews115 for mac-sierra (3.52 MB, application/zip)
2018-11-08 03:55 PST, Build Bot
no flags Details
Patch (32.47 KB, patch)
2018-11-08 10:30 PST, Ross Kirsling
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Ross Kirsling 2018-11-07 21:48:09 PST
U+180E is no longer a whitespace character
Comment 1 Ross Kirsling 2018-11-07 22:59:16 PST
Created attachment 354209 [details]
Patch
Comment 2 Ross Kirsling 2018-11-07 23:01:01 PST
Discovered via https://test262.report/browse/language/white-space. :)
Comment 3 Ross Kirsling 2018-11-07 23:54:06 PST
Created attachment 354211 [details]
Patch
Comment 4 Ross Kirsling 2018-11-08 00:12:27 PST
*** Bug 126608 has been marked as a duplicate of this bug. ***
Comment 5 Build Bot 2018-11-08 01:09:23 PST Comment hidden (obsolete)
Comment 6 Build Bot 2018-11-08 01:09:25 PST Comment hidden (obsolete)
Comment 7 Build Bot 2018-11-08 01:17:12 PST Comment hidden (obsolete)
Comment 8 Build Bot 2018-11-08 01:17:15 PST Comment hidden (obsolete)
Comment 9 Build Bot 2018-11-08 01:50:38 PST Comment hidden (obsolete)
Comment 10 Build Bot 2018-11-08 01:50:40 PST Comment hidden (obsolete)
Comment 11 Build Bot 2018-11-08 01:54:03 PST Comment hidden (obsolete)
Comment 12 Build Bot 2018-11-08 01:54:15 PST Comment hidden (obsolete)
Comment 13 Build Bot 2018-11-08 02:00:36 PST Comment hidden (obsolete)
Comment 14 Build Bot 2018-11-08 02:00:37 PST Comment hidden (obsolete)
Comment 15 Build Bot 2018-11-08 03:55:04 PST Comment hidden (obsolete)
Comment 16 Build Bot 2018-11-08 03:55:06 PST Comment hidden (obsolete)
Comment 17 Ross Kirsling 2018-11-08 10:30:24 PST
Created attachment 354248 [details]
Patch
Comment 18 Ross Kirsling 2018-11-08 12:42:45 PST
This should be good now -- sorry about the layout test spam. 😅
Comment 19 Saam Barati 2018-11-08 14:38:28 PST
Comment on attachment 354248 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=354248&action=review

r=me

> Source/JavaScriptCore/parser/Lexer.h:241
>  ALWAYS_INLINE bool Lexer<UChar>::isWhiteSpace(UChar ch)

Can we combine this w/ isStrWhiteSpace somehow inside ParseInt.h?
Comment 20 Ross Kirsling 2018-11-08 15:14:42 PST
(In reply to Saam Barati from comment #19)
> Comment on attachment 354248 [details]
> Patch
> 
> View in context:
> https://bugs.webkit.org/attachment.cgi?id=354248&action=review
> 
> r=me
> 
> > Source/JavaScriptCore/parser/Lexer.h:241
> >  ALWAYS_INLINE bool Lexer<UChar>::isWhiteSpace(UChar ch)
> 
> Can we combine this w/ isStrWhiteSpace somehow inside ParseInt.h?

Good point -- created bug 191439 to track this.
Comment 21 WebKit Commit Bot 2018-11-08 15:40:34 PST
Comment on attachment 354248 [details]
Patch

Clearing flags on attachment: 354248

Committed r238004: <https://trac.webkit.org/changeset/238004>
Comment 22 WebKit Commit Bot 2018-11-08 15:40:36 PST
All reviewed patches have been landed.  Closing bug.
Comment 23 Radar WebKit Bug Importer 2018-11-08 15:41:29 PST
<rdar://problem/45926530>