Bug 19139 - Wrong JavaScript time zone when time zone set to Colombo, Sri Lanka
Summary: Wrong JavaScript time zone when time zone set to Colombo, Sri Lanka
Status: RESOLVED WORKSFORME
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh PowerPC OS X 10.5
: P2 Normal
Assignee: Nobody
URL: http://www.4dpi.de/time.html
Keywords: HasReduction, InRadar, Regression
Depends on:
Blocks:
 
Reported: 2008-05-20 03:58 PDT by Hans Thiele
Modified: 2012-09-06 17:43 PDT (History)
4 users (show)

See Also:


Attachments
test case (249 bytes, text/html)
2008-05-20 04:02 PDT, Hans Thiele
no flags Details
screenshot (210.54 KB, image/png)
2008-05-20 04:06 PDT, Hans Thiele
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Hans Thiele 2008-05-20 03:58:01 PDT
When the time zone is set to IST (GMT +5.30) and the next city is set to "Colombo (Sri Lanka)", then JavaScript will add 24 hours to the actual time and display "GMT+2930 (IST)". With any other city in this time zone it displays the correct time "GMT+0530 (IST)". Other browser, also working with WebKit like Shiira or iCab, show the same bug while browser with an own engine like Opera or Firefox pass the test correctly.
The bug is very simple to show with this JavaScript command:

document.write(new Date());
Comment 1 Hans Thiele 2008-05-20 04:02:56 PDT
Created attachment 21251 [details]
test case
Comment 2 Hans Thiele 2008-05-20 04:06:31 PDT
Created attachment 21252 [details]
screenshot

The screenshot shows the same script in Safari and Firefox and also the time zone settings where the bug will work
Comment 3 Mark Rowe (bdash) 2008-05-20 11:26:49 PDT
Huh, that's very curious!
Comment 4 Mark Rowe (bdash) 2008-05-20 11:27:02 PDT
<rdar://problem/5949543>
Comment 5 Gavin Barraclough 2012-09-06 17:43:02 PDT
This works for me.