Bug 191175 - REGRESSION(r237547): Exception handlers should be aware of wide opcodes when JIT is disabled
Summary: REGRESSION(r237547): Exception handlers should be aware of wide opcodes when ...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Tadeu Zagallo
URL:
Keywords: InRadar
: 191168 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-11-01 16:04 PDT by Tadeu Zagallo
Modified: 2018-11-02 04:00 PDT (History)
9 users (show)

See Also:


Attachments
Patch (2.33 KB, patch)
2018-11-01 16:07 PDT, Tadeu Zagallo
no flags Details | Formatted Diff | Diff
Archive of layout-test-results from ews107 for mac-sierra-wk2 (3.22 MB, application/zip)
2018-11-01 18:18 PDT, Build Bot
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tadeu Zagallo 2018-11-01 16:04:23 PDT
https://bugs.webkit.org/show_bug.cgi?id=191108 did not handle the case where JIT is not enabled
Comment 1 Tadeu Zagallo 2018-11-01 16:07:38 PDT
Created attachment 353657 [details]
Patch
Comment 2 Keith Miller 2018-11-01 18:05:40 PDT
Comment on attachment 353657 [details]
Patch

r=me.
Comment 3 Build Bot 2018-11-01 18:18:26 PDT
Comment on attachment 353657 [details]
Patch

Attachment 353657 [details] did not pass mac-wk2-ews (mac-wk2):
Output: https://webkit-queues.webkit.org/results/9823227

New failing tests:
http/tests/security/anchor-download-block-crossorigin.html
Comment 4 Build Bot 2018-11-01 18:18:28 PDT
Created attachment 353671 [details]
Archive of layout-test-results from ews107 for mac-sierra-wk2

The attached test failures were seen while running run-webkit-tests on the mac-wk2-ews.
Bot: ews107  Port: mac-sierra-wk2  Platform: Mac OS X 10.12.6
Comment 5 WebKit Commit Bot 2018-11-02 03:46:42 PDT
Comment on attachment 353657 [details]
Patch

Clearing flags on attachment: 353657

Committed r237728: <https://trac.webkit.org/changeset/237728>
Comment 6 WebKit Commit Bot 2018-11-02 03:46:44 PDT
All reviewed patches have been landed.  Closing bug.
Comment 7 Radar WebKit Bug Importer 2018-11-02 03:47:37 PDT
<rdar://problem/45758686>
Comment 8 Guillaume Emont 2018-11-02 04:00:09 PDT
*** Bug 191168 has been marked as a duplicate of this bug. ***