Bug 19104 - WebKit does not focus radios and checkboxs on click (like windows expects)
: WebKit does not focus radios and checkboxs on click (like windows expects)
Status: RESOLVED DUPLICATE of bug 22261
Product: WebKit
Classification: Unclassified
Component: Forms
: 528+ (Nightly build)
: Macintosh Mac OS X 10.5
: P2 Normal
Assigned To: Nobody
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-16 14:09 PDT by Eric Seidel
Modified: 2011-07-05 13:18 PDT (History)
6 users (show)

See Also:


Attachments
test case (257 bytes, text/html)
2008-05-16 14:10 PDT, Eric Seidel
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Eric Seidel 2008-05-16 14:09:41 PDT
WebKit does not focus radios and checkboxs on click (like windows expects)

See attached test case.

Part of this is a web-compat issue, and part of this is a Windows-only issue.  This could be split into two bugs if necessary.  Fixing the web-compat issue will fix the windows-only issue, however, doing so will require hacking it so that the mac doesn't draw the focus ring (or actually change the focus, just send the event), which is why I've left this as one bug.
Comment 1 Eric Seidel 2008-05-16 14:10:01 PDT
Created attachment 21205 [details]
test case
Comment 2 Viatcheslav Ostapenko 2009-09-28 09:27:17 PDT
Patch submitted here: https://bugs.webkit.org/show_bug.cgi?id=22261
Comment 3 Simon Fraser (smfr) 2010-10-09 08:29:53 PDT
Forward dup, but the other has a patch.

*** This bug has been marked as a duplicate of bug 22261 ***
Comment 4 Zach Leatherman 2011-07-05 13:18:30 PDT
*** Bug 63944 has been marked as a duplicate of this bug. ***