Bug 190790 - Use WeakPtr and GenericTaskQueue within ObjC classes used by MediaPlayerPrivateAVFoundationObjC
Summary: Use WeakPtr and GenericTaskQueue within ObjC classes used by MediaPlayerPriva...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Jer Noble
URL:
Keywords: InRadar
: 190837 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-10-22 03:16 PDT by Jer Noble
Modified: 2018-10-24 03:03 PDT (History)
7 users (show)

See Also:


Attachments
Patch (30.54 KB, patch)
2018-10-22 03:27 PDT, Jer Noble
no flags Details | Formatted Diff | Diff
Patch (30.64 KB, patch)
2018-10-22 05:08 PDT, Jer Noble
no flags Details | Formatted Diff | Diff
Archive of layout-test-results from ews204 for win-future (12.71 MB, application/zip)
2018-10-22 07:02 PDT, EWS Watchlist
no flags Details
Archive of layout-test-results from ews112 for mac-sierra (3.94 MB, application/zip)
2018-10-22 07:25 PDT, EWS Watchlist
no flags Details
Archive of layout-test-results from ews115 for mac-sierra (3.94 MB, application/zip)
2018-10-22 09:29 PDT, EWS Watchlist
no flags Details
Patch for landing (31.10 KB, patch)
2018-10-23 04:32 PDT, Jer Noble
no flags Details | Formatted Diff | Diff
Patch for landing (31.05 KB, patch)
2018-10-23 23:50 PDT, Jer Noble
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jer Noble 2018-10-22 03:16:05 PDT
Use WeakPtr and GenericTaskQueue within ObjC classes used by MediaPlayerPrivateAVFoundationObjC
Comment 1 Jer Noble 2018-10-22 03:27:13 PDT
Created attachment 352883 [details]
Patch
Comment 2 Jer Noble 2018-10-22 05:08:59 PDT
Created attachment 352886 [details]
Patch
Comment 3 EWS Watchlist 2018-10-22 07:02:24 PDT
Comment on attachment 352886 [details]
Patch

Attachment 352886 [details] did not pass win-ews (win):
Output: https://webkit-queues.webkit.org/results/9693492

New failing tests:
webanimations/leak-document-with-web-animation.html
Comment 4 EWS Watchlist 2018-10-22 07:02:36 PDT
Created attachment 352889 [details]
Archive of layout-test-results from ews204 for win-future

The attached test failures were seen while running run-webkit-tests on the win-ews.
Bot: ews204  Port: win-future  Platform: CYGWIN_NT-6.1-2.10.0-0.325-5-3-x86_64-64bit
Comment 5 EWS Watchlist 2018-10-22 07:25:18 PDT
Comment on attachment 352886 [details]
Patch

Attachment 352886 [details] did not pass mac-debug-ews (mac):
Output: https://webkit-queues.webkit.org/results/9693479

New failing tests:
inspector/console/webcore-logging.html
media/video-src-blob-using-open-panel.html
imported/w3c/web-platform-tests/2dcontext/imagebitmap/createImageBitmap-drawImage.html
media/sources-fallback-codecs.html
imported/w3c/web-platform-tests/2dcontext/imagebitmap/createImageBitmap-invalid-args.html
imported/w3c/web-platform-tests/media-source/mediasource-detach.html
imported/w3c/web-platform-tests/2dcontext/imagebitmap/createImageBitmap-transfer.html
media/audio-data-url.html
http/tests/media/clearkey/clear-key-hls-aes128.html
http/tests/media/clearkey/collect-webkit-media-session.html
media/video-src-blob.html
media/unsupported-rtsp.html
imported/w3c/web-platform-tests/media-source/mediasource-avtracks.html
fast/forms/form-associated-element-crash3.html
Comment 6 EWS Watchlist 2018-10-22 07:25:20 PDT
Created attachment 352891 [details]
Archive of layout-test-results from ews112 for mac-sierra

The attached test failures were seen while running run-webkit-tests on the mac-debug-ews.
Bot: ews112  Port: mac-sierra  Platform: Mac OS X 10.12.6
Comment 7 EWS Watchlist 2018-10-22 09:29:46 PDT
Comment on attachment 352886 [details]
Patch

Attachment 352886 [details] did not pass mac-debug-ews (mac):
Output: https://webkit-queues.webkit.org/results/9694291

New failing tests:
inspector/console/webcore-logging.html
media/video-src-blob-using-open-panel.html
imported/w3c/web-platform-tests/2dcontext/imagebitmap/createImageBitmap-drawImage.html
media/sources-fallback-codecs.html
imported/w3c/web-platform-tests/2dcontext/imagebitmap/createImageBitmap-invalid-args.html
imported/w3c/web-platform-tests/media-source/mediasource-detach.html
imported/w3c/web-platform-tests/2dcontext/imagebitmap/createImageBitmap-transfer.html
media/audio-data-url.html
http/tests/media/clearkey/clear-key-hls-aes128.html
http/tests/media/clearkey/collect-webkit-media-session.html
media/video-src-blob.html
media/unsupported-rtsp.html
imported/w3c/web-platform-tests/media-source/mediasource-avtracks.html
fast/forms/form-associated-element-crash3.html
Comment 8 EWS Watchlist 2018-10-22 09:29:48 PDT
Created attachment 352894 [details]
Archive of layout-test-results from ews115 for mac-sierra

The attached test failures were seen while running run-webkit-tests on the mac-debug-ews.
Bot: ews115  Port: mac-sierra  Platform: Mac OS X 10.12.6
Comment 9 Jer Noble 2018-10-23 04:32:19 PDT
Created attachment 352968 [details]
Patch for landing
Comment 10 WebKit Commit Bot 2018-10-23 07:41:05 PDT
Comment on attachment 352968 [details]
Patch for landing

Clearing flags on attachment: 352968

Committed r237350: <https://trac.webkit.org/changeset/237350>
Comment 11 WebKit Commit Bot 2018-10-23 07:41:07 PDT
All reviewed patches have been landed.  Closing bug.
Comment 12 Radar WebKit Bug Importer 2018-10-23 07:42:37 PDT
<rdar://problem/45487049>
Comment 13 Truitt Savell 2018-10-23 11:29:43 PDT
It looks like the changes in https://trac.webkit.org/changeset/237350/webkit

has caused a crash in security/contentSecurityPolicy/video-with-data-url-allowed-by-media-src-star.html

History: https://webkit-test-results.webkit.org/dashboards/flakiness_dashboard.html#showAllRuns=true&tests=security%2FcontentSecurityPolicy%2Fvideo-with-data-url-allowed-by-media-src-star.html

Crash:
https://build.webkit.org/results/Apple%20High%20Sierra%20Debug%20WK1%20(Tests)/r237350%20(6087)/security/contentSecurityPolicy/video-with-data-url-allowed-by-media-src-star-crash-log.txt

I reproduced this Crash using:
run-webkit-tests --root debug-237350 security/contentSecurityPolicy/video-with-data-url-allowed-by-media-src-star.html --iterations 500 -f --debug -1

no crash will occur on a debug build of 237349.
Comment 15 Truitt Savell 2018-10-23 13:02:57 PDT
Reverted r237350 for reason:

Caused several Crashes cross multiple tests and platforms.

Committed r237364: <https://trac.webkit.org/changeset/237364>
Comment 16 Ryan Haddad 2018-10-23 13:05:39 PDT
*** Bug 190837 has been marked as a duplicate of this bug. ***
Comment 17 Jer Noble 2018-10-23 23:41:50 PDT
(In reply to Truitt Savell from comment #15)
> Reverted r237350 for reason:
> 
> Caused several Crashes cross multiple tests and platforms.
> 
> Committed r237364: <https://trac.webkit.org/changeset/237364>

Looks like this is due to a stray ASSERT that is no longer relevant. Will post new patch.
Comment 18 Jer Noble 2018-10-23 23:50:14 PDT
Created attachment 353024 [details]
Patch for landing
Comment 19 Jer Noble 2018-10-24 03:03:47 PDT
Committed r237378: <https://trac.webkit.org/changeset/237378>