Bug 190788 - Remove non-standard -webkit-margin-collapse CSS property and longhands
Summary: Remove non-standard -webkit-margin-collapse CSS property and longhands
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: CSS (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Tim Nguyen (:ntim)
URL:
Keywords: InRadar
: 204956 (view as bug list)
Depends on:
Blocks: 234692
  Show dependency treegraph
 
Reported: 2018-10-22 01:45 PDT by Simon Fraser (smfr)
Modified: 2021-12-26 11:36 PST (History)
19 users (show)

See Also:


Attachments
Patch (100.48 KB, patch)
2021-12-24 07:06 PST, Tim Nguyen (:ntim)
ews-feeder: commit-queue-
Details | Formatted Diff | Diff
Patch (105.45 KB, patch)
2021-12-24 07:57 PST, Tim Nguyen (:ntim)
no flags Details | Formatted Diff | Diff
Patch (113.95 KB, patch)
2021-12-24 09:22 PST, Tim Nguyen (:ntim)
simon.fraser: review+
Details | Formatted Diff | Diff
Patch (113.93 KB, patch)
2021-12-24 10:33 PST, Tim Nguyen (:ntim)
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Simon Fraser (smfr) 2018-10-22 01:45:51 PDT
-webkit-margin-collpase is a non-standard extension added in https://trac.webkit.org/changeset/7362/webkit. I wonder if we can remove it.
Comment 1 Simon Fraser (smfr) 2018-10-22 04:23:16 PDT
There's a mention here:
https://stackoverflow.com/questions/11046596/collapsing-margin-on-legend-tag

Chrome usage counting:
https://www.chromestatus.com/metrics/css/timeline/popularity/269
This probably over-counts, according to Ian K.
Comment 2 Manuel Rego Casasnovas 2019-12-11 05:28:09 PST
*** Bug 204956 has been marked as a duplicate of this bug. ***
Comment 3 Manuel Rego Casasnovas 2019-12-11 05:29:09 PST
Just for future reference, this is the comment from ikilpatrick@ on the duplicated bug:
  Blink is going to attempt to remove this in the M81 release, see:
  https://bugs.chromium.org/p/chromium/issues/detail?id=1030765
  https://groups.google.com/a/chromium.org/forum/#!msg/blink-dev/ewWQH9vEqtI/L2r2WFhPBAAJ
Comment 4 Tim Nguyen (:ntim) 2021-12-24 07:06:53 PST
Created attachment 447936 [details]
Patch
Comment 5 Tim Nguyen (:ntim) 2021-12-24 07:57:29 PST
Created attachment 447939 [details]
Patch
Comment 6 Tim Nguyen (:ntim) 2021-12-24 09:22:41 PST
Created attachment 447943 [details]
Patch
Comment 7 Tim Nguyen (:ntim) 2021-12-24 10:06:19 PST
Comment on attachment 447943 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=447943&action=review

> LayoutTests/ChangeLog:3
> +        Rqa"§emove non-standard -webkit-margin-collapse CSS property and longhands

nit: fix commit message here
Comment 8 Tim Nguyen (:ntim) 2021-12-24 10:33:07 PST
Created attachment 447944 [details]
Patch
Comment 9 Tim Nguyen (:ntim) 2021-12-24 10:55:50 PST
Committed r287429 (245564@trunk): <https://commits.webkit.org/245564@trunk>
Comment 10 Radar WebKit Bug Importer 2021-12-24 10:56:22 PST
<rdar://problem/86895519>