RESOLVED FIXED 190359
Enable external playback for video in element fullscreen.
https://bugs.webkit.org/show_bug.cgi?id=190359
Summary Enable external playback for video in element fullscreen.
Jeremy Jones
Reported 2018-10-08 10:42:01 PDT
Enable external playback for video in element fullscreen.
Attachments
Patch (6.93 KB, patch)
2018-10-08 10:47 PDT, Jeremy Jones
no flags
Patch (7.77 KB, patch)
2018-10-08 12:38 PDT, Jeremy Jones
no flags
Patch (7.77 KB, patch)
2018-10-08 12:46 PDT, Jeremy Jones
no flags
Patch (7.85 KB, patch)
2018-10-08 13:00 PDT, Jeremy Jones
no flags
Patch (8.70 KB, patch)
2018-11-02 11:13 PDT, Jeremy Jones
no flags
Patch For Landing (8.82 KB, patch)
2018-11-05 09:50 PST, Jeremy Jones
no flags
Jeremy Jones
Comment 1 2018-10-08 10:47:46 PDT
Jeremy Jones
Comment 2 2018-10-08 10:48:26 PDT
Jeremy Jones
Comment 3 2018-10-08 12:38:18 PDT
Jeremy Jones
Comment 4 2018-10-08 12:46:35 PDT
Jeremy Jones
Comment 5 2018-10-08 13:00:21 PDT
Jeremy Jones
Comment 6 2018-11-02 11:13:45 PDT
Jer Noble
Comment 7 2018-11-02 11:17:33 PDT
Comment on attachment 353716 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=353716&action=review r=me with nits > Source/WebCore/html/HTMLMediaElement.h:737 > + bool mediaPlayerVideoFullscreenStandby() const final { return m_videoFullscreenStandby; } This is a verb that wants to be a noun. Could we do mediaPlayerIsVideoFullscreenStandby()? (and in all the related declarations) > Source/WebCore/platform/graphics/MediaPlayer.cpp:724 > +void MediaPlayer::setVideoFullscreenStandby(bool isStandby) > +{ > + m_private->setVideoFullscreenStandby(isStandby); > +} We pass isStandby in here but never use it. Could we rename this "videoFullscreenStandbyChanged()"?
Jeremy Jones
Comment 8 2018-11-02 13:32:36 PDT
Comment on attachment 353716 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=353716&action=review >> Source/WebCore/html/HTMLMediaElement.h:737 >> + bool mediaPlayerVideoFullscreenStandby() const final { return m_videoFullscreenStandby; } > > This is a verb that wants to be a noun. Could we do mediaPlayerIsVideoFullscreenStandby()? (and in all the related declarations) Done. >> Source/WebCore/platform/graphics/MediaPlayer.cpp:724 >> +} > > We pass isStandby in here but never use it. Could we rename this "videoFullscreenStandbyChanged()"? Done.
Jeremy Jones
Comment 9 2018-11-05 09:50:29 PST
Created attachment 353882 [details] Patch For Landing
WebKit Commit Bot
Comment 10 2018-11-16 16:49:58 PST
Comment on attachment 353882 [details] Patch For Landing Clearing flags on attachment: 353882 Committed r238327: <https://trac.webkit.org/changeset/238327>
WebKit Commit Bot
Comment 11 2018-11-16 16:49:59 PST
All reviewed patches have been landed. Closing bug.
Note You need to log in before you can comment on or make changes to this bug.