Bug 19015 - GTK build fails when database support is disabled
Summary: GTK build fails when database support is disabled
Status: RESOLVED DUPLICATE of bug 18825
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKitGTK (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.5
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-05-12 13:44 PDT by Richard Hult
Modified: 2008-05-20 00:34 PDT (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Richard Hult 2008-05-12 13:44:43 PDT
The GTK+ build fails with the following error:

WebKit/gtk/WebCoreSupport/ChromeClientGtk.cpp:33:29: error: DatabaseTracker.h: No such file or directory
WebKit/gtk/WebCoreSupport/ChromeClientGtk.cpp: In member function ‘virtual void WebKit::ChromeClient::exceededDatabaseQuota(WebCore::Frame*, const WebCore::String&)’:
WebKit/gtk/WebCoreSupport/ChromeClientGtk.cpp:318: error: ‘DatabaseTracker’ has not been declared

when building with --disable-video --with-http-backend=curl --disable-dom-storage --disable-database --disable-icon-database --disable-svg --with-target=quartz --with-font-backend=pango --disable-offline-web-applications

(The main point being that all the database related features are disabled.)
Comment 1 Josh Saddler 2008-05-18 02:52:09 PDT
Duplicate of bug 18825:

https://bugs.webkit.org/show_bug.cgi?id=18825
Comment 2 Richard Hult 2008-05-20 00:34:33 PDT
Ah, I missed that one, thanks.

*** This bug has been marked as a duplicate of 18825 ***