Bug 190091 - Unify implementation in VideoFullscreenInterfaceAVKit
Summary: Unify implementation in VideoFullscreenInterfaceAVKit
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Media (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Jeremy Jones
URL:
Keywords: InRadar
Depends on: 190207
Blocks:
  Show dependency treegraph
 
Reported: 2018-09-28 14:28 PDT by Jeremy Jones
Modified: 2018-10-04 16:52 PDT (History)
4 users (show)

See Also:


Attachments
Patch (30.79 KB, patch)
2018-09-28 14:29 PDT, Jeremy Jones
no flags Details | Formatted Diff | Diff
Patch (33.45 KB, patch)
2018-09-28 14:32 PDT, Jeremy Jones
no flags Details | Formatted Diff | Diff
Patch for landing. (32.83 KB, patch)
2018-09-30 17:58 PDT, Jeremy Jones
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jeremy Jones 2018-09-28 14:28:49 PDT
Unify implementation in VideoFullscreenInterfaceAVKit
Comment 1 Jeremy Jones 2018-09-28 14:29:21 PDT
Created attachment 351111 [details]
Patch
Comment 2 Jeremy Jones 2018-09-28 14:32:04 PDT
Created attachment 351113 [details]
Patch
Comment 3 Jeremy Jones 2018-09-28 14:32:35 PDT
rdar://problem/44734523
Comment 4 Jeremy Jones 2018-09-30 17:58:18 PDT
Created attachment 351220 [details]
Patch for landing.
Comment 5 WebKit Commit Bot 2018-10-01 11:00:05 PDT
Comment on attachment 351220 [details]
Patch for landing.

Clearing flags on attachment: 351220

Committed r236671: <https://trac.webkit.org/changeset/236671>
Comment 6 Ryan Haddad 2018-10-02 10:11:23 PDT
This was rolled out in https://trac.webkit.org/changeset/236748/webkit because it depended upon https://trac.webkit.org/changeset/236624/webkit, which was rolled out due to test regressions.
Comment 7 Jeremy Jones 2018-10-04 16:27:23 PDT
Patch that necessitated the rebased "patch for landing" has been rolled out, taking this patch with it. So I'm re-submitting the original patch, pre-rebase.
Comment 8 WebKit Commit Bot 2018-10-04 16:52:46 PDT
Comment on attachment 351113 [details]
Patch

Clearing flags on attachment: 351113

Committed r236860: <https://trac.webkit.org/changeset/236860>
Comment 9 WebKit Commit Bot 2018-10-04 16:52:48 PDT
All reviewed patches have been landed.  Closing bug.