Bug 190059 - Increase the timeout for iOS Simulator data migration
Summary: Increase the timeout for iOS Simulator data migration
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: Other
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Ryan Haddad
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2018-09-27 15:42 PDT by Ryan Haddad
Modified: 2018-09-27 17:51 PDT (History)
6 users (show)

See Also:


Attachments
Patch (3.38 KB, patch)
2018-09-27 16:17 PDT, Ryan Haddad
no flags Details | Formatted Diff | Diff
Patch (3.38 KB, patch)
2018-09-27 17:16 PDT, Ryan Haddad
aakash_jain: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Ryan Haddad 2018-09-27 15:42:11 PDT
Increase the timeout for iOS Simulator data migration since 3 minutes isn't always enough time for the data migrator to complete when booting up multiple iOS Simulators
Comment 1 Ryan Haddad 2018-09-27 16:17:04 PDT
Created attachment 351018 [details]
Patch
Comment 2 Jonathan Bedard 2018-09-27 17:15:13 PDT
Comment on attachment 351018 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=351018&action=review

> Tools/Scripts/webkitpy/xcode/simulated_device.py:64
> +    DEFAULT_TIMEOUT = 60

I think this should be 600
Comment 3 Ryan Haddad 2018-09-27 17:16:18 PDT
Created attachment 351027 [details]
Patch
Comment 4 Jonathan Bedard 2018-09-27 17:16:41 PDT
Unofficial r=me.
Comment 5 Aakash Jain 2018-09-27 17:30:23 PDT
Comment on attachment 351027 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=351027&action=review

> Tools/Scripts/webkitpy/xcode/simulated_device.py:64
> +    DEFAULT_TIMEOUT = 600

This variable can be named better, to indicate what kind of timeout it is.
Comment 6 Ryan Haddad 2018-09-27 17:41:37 PDT
(In reply to Aakash Jain from comment #5)
> Comment on attachment 351027 [details]
> Patch
> 
> View in context:
> https://bugs.webkit.org/attachment.cgi?id=351027&action=review
> 
> > Tools/Scripts/webkitpy/xcode/simulated_device.py:64
> > +    DEFAULT_TIMEOUT = 600
> 
> This variable can be named better, to indicate what kind of timeout it is.
Perhaps SIMULATOR_BOOT_TIMEOUT is more appropriate.
Comment 7 Ryan Haddad 2018-09-27 17:50:55 PDT
Landed in https://trac.webkit.org/r236579
Comment 8 Radar WebKit Bug Importer 2018-09-27 17:51:29 PDT
<rdar://problem/44850684>