WebKit Bugzilla
New
Browse
Log In
×
Sign in with GitHub
or
Remember my login
Create Account
·
Forgot Password
Forgotten password account recovery
RESOLVED FIXED
189778
[JSC] Enable LLInt ASM interpreter on X64 and ARM64 in non JIT configuration
https://bugs.webkit.org/show_bug.cgi?id=189778
Summary
[JSC] Enable LLInt ASM interpreter on X64 and ARM64 in non JIT configuration
Yusuke Suzuki
Reported
2018-09-19 22:46:13 PDT
LLInt ASM interpreter is 2x faster than CLoop interpreter. We would like to enable it for non JIT configuration in x64 and ARM64. I don't consider enabling this for the other CPU architectures now since no buildbot exists for non JIT configurations.
Attachments
Patch
(64.64 KB, patch)
2018-09-19 22:49 PDT
,
Yusuke Suzuki
no flags
Details
Formatted Diff
Diff
Patch
(67.17 KB, patch)
2018-09-21 02:00 PDT
,
Yusuke Suzuki
no flags
Details
Formatted Diff
Diff
Patch
(69.26 KB, patch)
2018-09-21 02:12 PDT
,
Yusuke Suzuki
no flags
Details
Formatted Diff
Diff
Patch
(71.72 KB, patch)
2018-09-21 02:31 PDT
,
Yusuke Suzuki
no flags
Details
Formatted Diff
Diff
Patch
(71.88 KB, patch)
2018-09-21 06:56 PDT
,
Yusuke Suzuki
keith_miller
: review+
Details
Formatted Diff
Diff
Patch
(71.67 KB, patch)
2018-09-21 19:55 PDT
,
Yusuke Suzuki
no flags
Details
Formatted Diff
Diff
Patch
(71.38 KB, patch)
2018-09-21 20:02 PDT
,
Yusuke Suzuki
no flags
Details
Formatted Diff
Diff
Show Obsolete
(5)
View All
Add attachment
proposed patch, testcase, etc.
Yusuke Suzuki
Comment 1
2018-09-19 22:47:06 PDT
Background:
https://lists.webkit.org/pipermail/webkit-dev/2018-September/030157.html
Yusuke Suzuki
Comment 2
2018-09-19 22:49:15 PDT
Created
attachment 350170
[details]
Patch
Yusuke Suzuki
Comment 3
2018-09-21 02:00:17 PDT
Created
attachment 350338
[details]
Patch
EWS Watchlist
Comment 4
2018-09-21 02:01:51 PDT
Attachment 350338
[details]
did not pass style-queue: ERROR: Source/JavaScriptCore/jit/HostCallReturnValue.cpp:57: The parameter name """" adds no information, so it should be removed. [readability/parameter_name] [5] ERROR: Source/JavaScriptCore/jit/HostCallReturnValue.cpp:73: The parameter name """" adds no information, so it should be removed. [readability/parameter_name] [5] ERROR: Source/JavaScriptCore/jit/HostCallReturnValue.cpp:86: The parameter name """" adds no information, so it should be removed. [readability/parameter_name] [5] ERROR: Source/JavaScriptCore/jit/HostCallReturnValue.cpp:97: The parameter name """" adds no information, so it should be removed. [readability/parameter_name] [5] ERROR: Source/JavaScriptCore/jit/HostCallReturnValue.cpp:108: The parameter name """" adds no information, so it should be removed. [readability/parameter_name] [5] ERROR: Source/JavaScriptCore/jit/HostCallReturnValue.cpp:130: The parameter name """" adds no information, so it should be removed. [readability/parameter_name] [5] Total errors found: 6 in 56 files If any of these errors are false positives, please file a bug against check-webkit-style.
Yusuke Suzuki
Comment 5
2018-09-21 02:12:05 PDT
Created
attachment 350340
[details]
Patch
EWS Watchlist
Comment 6
2018-09-21 02:15:10 PDT
Attachment 350340
[details]
did not pass style-queue: ERROR: Source/JavaScriptCore/jit/HostCallReturnValue.cpp:57: The parameter name """" adds no information, so it should be removed. [readability/parameter_name] [5] ERROR: Source/JavaScriptCore/jit/HostCallReturnValue.cpp:73: The parameter name """" adds no information, so it should be removed. [readability/parameter_name] [5] ERROR: Source/JavaScriptCore/jit/HostCallReturnValue.cpp:86: The parameter name """" adds no information, so it should be removed. [readability/parameter_name] [5] ERROR: Source/JavaScriptCore/jit/HostCallReturnValue.cpp:97: The parameter name """" adds no information, so it should be removed. [readability/parameter_name] [5] ERROR: Source/JavaScriptCore/jit/HostCallReturnValue.cpp:108: The parameter name """" adds no information, so it should be removed. [readability/parameter_name] [5] ERROR: Source/JavaScriptCore/jit/HostCallReturnValue.cpp:130: The parameter name """" adds no information, so it should be removed. [readability/parameter_name] [5] Total errors found: 6 in 57 files If any of these errors are false positives, please file a bug against check-webkit-style.
Yusuke Suzuki
Comment 7
2018-09-21 02:31:47 PDT
Created
attachment 350342
[details]
Patch
EWS Watchlist
Comment 8
2018-09-21 02:34:27 PDT
Attachment 350342
[details]
did not pass style-queue: ERROR: Source/JavaScriptCore/jit/HostCallReturnValue.cpp:57: The parameter name """" adds no information, so it should be removed. [readability/parameter_name] [5] ERROR: Source/JavaScriptCore/jit/HostCallReturnValue.cpp:73: The parameter name """" adds no information, so it should be removed. [readability/parameter_name] [5] ERROR: Source/JavaScriptCore/jit/HostCallReturnValue.cpp:86: The parameter name """" adds no information, so it should be removed. [readability/parameter_name] [5] ERROR: Source/JavaScriptCore/jit/HostCallReturnValue.cpp:97: The parameter name """" adds no information, so it should be removed. [readability/parameter_name] [5] ERROR: Source/JavaScriptCore/jit/HostCallReturnValue.cpp:108: The parameter name """" adds no information, so it should be removed. [readability/parameter_name] [5] ERROR: Source/JavaScriptCore/jit/HostCallReturnValue.cpp:130: The parameter name """" adds no information, so it should be removed. [readability/parameter_name] [5] Total errors found: 6 in 58 files If any of these errors are false positives, please file a bug against check-webkit-style.
Yusuke Suzuki
Comment 9
2018-09-21 06:56:16 PDT
Created
attachment 350355
[details]
Patch
EWS Watchlist
Comment 10
2018-09-21 06:58:18 PDT
Attachment 350355
[details]
did not pass style-queue: ERROR: Source/JavaScriptCore/jit/HostCallReturnValue.cpp:57: The parameter name """" adds no information, so it should be removed. [readability/parameter_name] [5] ERROR: Source/JavaScriptCore/jit/HostCallReturnValue.cpp:73: The parameter name """" adds no information, so it should be removed. [readability/parameter_name] [5] ERROR: Source/JavaScriptCore/jit/HostCallReturnValue.cpp:86: The parameter name """" adds no information, so it should be removed. [readability/parameter_name] [5] ERROR: Source/JavaScriptCore/jit/HostCallReturnValue.cpp:97: The parameter name """" adds no information, so it should be removed. [readability/parameter_name] [5] ERROR: Source/JavaScriptCore/jit/HostCallReturnValue.cpp:108: The parameter name """" adds no information, so it should be removed. [readability/parameter_name] [5] ERROR: Source/JavaScriptCore/jit/HostCallReturnValue.cpp:130: The parameter name """" adds no information, so it should be removed. [readability/parameter_name] [5] Total errors found: 6 in 58 files If any of these errors are false positives, please file a bug against check-webkit-style.
Keith Miller
Comment 11
2018-09-21 10:37:54 PDT
Comment on
attachment 350355
[details]
Patch View in context:
https://bugs.webkit.org/attachment.cgi?id=350355&action=review
r=me with some nits.
> Source/JavaScriptCore/ChangeLog:10 > + configuration in X86_64 and ARM64.
Nit: configurations
> Source/JavaScriptCore/ChangeLog:12 > + This patch enables LLInt for non JIT in X86_64 and ARM64 architectures.
Nit: maybe "for non JIT in" => "for non JIT builds on"
> Source/JavaScriptCore/ChangeLog:14 > + configuration. But it is wrong in the new scenario since we have a buildx
typo: "buildx" => "build"?
> Source/JavaScriptCore/jit/HostCallReturnValue.cpp:-38 > -// Nothing to see here.
Lol solid comment.
Yusuke Suzuki
Comment 12
2018-09-21 19:46:53 PDT
Comment on
attachment 350355
[details]
Patch View in context:
https://bugs.webkit.org/attachment.cgi?id=350355&action=review
Thank you!
>> Source/JavaScriptCore/ChangeLog:10 >> + configuration in X86_64 and ARM64. > > Nit: configurations
Fixed.
>> Source/JavaScriptCore/ChangeLog:12 >> + This patch enables LLInt for non JIT in X86_64 and ARM64 architectures. > > Nit: maybe "for non JIT in" => "for non JIT builds on"
Fixed.
>> Source/JavaScriptCore/ChangeLog:14 >> + configuration. But it is wrong in the new scenario since we have a buildx > > typo: "buildx" => "build"?
Fixed.
Yusuke Suzuki
Comment 13
2018-09-21 19:55:47 PDT
Created
attachment 350480
[details]
Patch
Yusuke Suzuki
Comment 14
2018-09-21 20:02:55 PDT
Created
attachment 350482
[details]
Patch
EWS Watchlist
Comment 15
2018-09-21 20:02:57 PDT
Attachment 350480
[details]
did not pass style-queue: ERROR: Source/JavaScriptCore/jit/HostCallReturnValue.cpp:57: The parameter name """" adds no information, so it should be removed. [readability/parameter_name] [5] ERROR: Source/JavaScriptCore/jit/HostCallReturnValue.cpp:73: The parameter name """" adds no information, so it should be removed. [readability/parameter_name] [5] ERROR: Source/JavaScriptCore/jit/HostCallReturnValue.cpp:86: The parameter name """" adds no information, so it should be removed. [readability/parameter_name] [5] ERROR: Source/JavaScriptCore/jit/HostCallReturnValue.cpp:97: The parameter name """" adds no information, so it should be removed. [readability/parameter_name] [5] ERROR: Source/JavaScriptCore/jit/HostCallReturnValue.cpp:108: The parameter name """" adds no information, so it should be removed. [readability/parameter_name] [5] ERROR: Source/JavaScriptCore/jit/HostCallReturnValue.cpp:130: The parameter name """" adds no information, so it should be removed. [readability/parameter_name] [5] Total errors found: 6 in 57 files If any of these errors are false positives, please file a bug against check-webkit-style.
EWS Watchlist
Comment 16
2018-09-21 20:23:35 PDT
Attachment 350482
[details]
did not pass style-queue: ERROR: Source/JavaScriptCore/jit/HostCallReturnValue.cpp:57: The parameter name """" adds no information, so it should be removed. [readability/parameter_name] [5] ERROR: Source/JavaScriptCore/jit/HostCallReturnValue.cpp:73: The parameter name """" adds no information, so it should be removed. [readability/parameter_name] [5] ERROR: Source/JavaScriptCore/jit/HostCallReturnValue.cpp:86: The parameter name """" adds no information, so it should be removed. [readability/parameter_name] [5] ERROR: Source/JavaScriptCore/jit/HostCallReturnValue.cpp:97: The parameter name """" adds no information, so it should be removed. [readability/parameter_name] [5] ERROR: Source/JavaScriptCore/jit/HostCallReturnValue.cpp:108: The parameter name """" adds no information, so it should be removed. [readability/parameter_name] [5] ERROR: Source/JavaScriptCore/jit/HostCallReturnValue.cpp:130: The parameter name """" adds no information, so it should be removed. [readability/parameter_name] [5] Total errors found: 6 in 57 files If any of these errors are false positives, please file a bug against check-webkit-style.
Yusuke Suzuki
Comment 17
2018-09-21 22:26:50 PDT
Committed
r236381
: <
https://trac.webkit.org/changeset/236381
>
Radar WebKit Bug Importer
Comment 18
2018-09-21 22:27:22 PDT
<
rdar://problem/44701303
>
Note
You need to
log in
before you can comment on or make changes to this bug.
Top of Page
Format For Printing
XML
Clone This Bug