Bug 189764 - Import WPT tests for css custom properties api
Summary: Import WPT tests for css custom properties api
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks: 189692
  Show dependency treegraph
 
Reported: 2018-09-19 13:38 PDT by Justin Michaud
Modified: 2018-09-24 17:06 PDT (History)
8 users (show)

See Also:


Attachments
Patch (136.52 KB, patch)
2018-09-21 19:46 PDT, Justin Michaud
no flags Details | Formatted Diff | Diff
Archive of layout-test-results from ews100 for mac-sierra (2.44 MB, application/zip)
2018-09-21 20:50 PDT, Build Bot
no flags Details
Archive of layout-test-results from ews117 for mac-sierra (3.15 MB, application/zip)
2018-09-21 21:46 PDT, Build Bot
no flags Details
Patch (137.77 KB, patch)
2018-09-24 14:20 PDT, Justin Michaud
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Comment 1 Justin Michaud 2018-09-21 19:46:38 PDT
Created attachment 350478 [details]
Patch
Comment 2 Build Bot 2018-09-21 20:50:54 PDT
Comment on attachment 350478 [details]
Patch

Attachment 350478 [details] did not pass mac-ews (mac):
Output: https://webkit-queues.webkit.org/results/9307265

New failing tests:
imported/w3c/web-platform-tests/css/css-properties-values-api/var-reference-registered-properties.html
imported/w3c/web-platform-tests/css/css-properties-values-api/registered-property-initial.html
imported/w3c/web-platform-tests/css/css-properties-values-api/var-reference-registered-properties-cycles.html
imported/w3c/web-platform-tests/css/css-properties-values-api/property-cascade.html
imported/w3c/web-platform-tests/css/css-properties-values-api/typedom.tentative.html
imported/w3c/web-platform-tests/css/css-properties-values-api/registered-properties-inheritance.html
imported/w3c/web-platform-tests/css/css-properties-values-api/unit-cycles.html
imported/w3c/web-platform-tests/css/css-properties-values-api/url-resolution.html
imported/w3c/web-platform-tests/css/css-properties-values-api/registered-property-computation.html
imported/w3c/web-platform-tests/css/css-properties-values-api/register-property.html
imported/w3c/web-platform-tests/css/css-properties-values-api/register-property-syntax-parsing.html
imported/w3c/web-platform-tests/css/css-properties-values-api/registered-property-cssom.html
Comment 3 Build Bot 2018-09-21 20:50:56 PDT
Created attachment 350485 [details]
Archive of layout-test-results from ews100 for mac-sierra

The attached test failures were seen while running run-webkit-tests on the mac-ews.
Bot: ews100  Port: mac-sierra  Platform: Mac OS X 10.12.6
Comment 4 Build Bot 2018-09-21 21:46:00 PDT
Comment on attachment 350478 [details]
Patch

Attachment 350478 [details] did not pass mac-debug-ews (mac):
Output: https://webkit-queues.webkit.org/results/9307378

New failing tests:
imported/w3c/web-platform-tests/css/css-properties-values-api/var-reference-registered-properties.html
imported/w3c/web-platform-tests/css/css-properties-values-api/registered-property-initial.html
imported/w3c/web-platform-tests/css/css-properties-values-api/registered-properties-inheritance.html
imported/w3c/web-platform-tests/css/css-properties-values-api/property-cascade.html
imported/w3c/web-platform-tests/css/css-properties-values-api/typedom.tentative.html
imported/w3c/web-platform-tests/css/css-properties-values-api/var-reference-registered-properties-cycles.html
imported/w3c/web-platform-tests/css/css-properties-values-api/unit-cycles.html
imported/w3c/web-platform-tests/css/css-properties-values-api/url-resolution.html
imported/w3c/web-platform-tests/css/css-properties-values-api/registered-property-computation.html
imported/w3c/web-platform-tests/css/css-properties-values-api/register-property.html
imported/w3c/web-platform-tests/css/css-properties-values-api/register-property-syntax-parsing.html
imported/w3c/web-platform-tests/css/css-properties-values-api/registered-property-cssom.html
Comment 5 Build Bot 2018-09-21 21:46:01 PDT
Created attachment 350495 [details]
Archive of layout-test-results from ews117 for mac-sierra

The attached test failures were seen while running run-webkit-tests on the mac-debug-ews.
Bot: ews117  Port: mac-sierra  Platform: Mac OS X 10.12.6
Comment 6 Justin Michaud 2018-09-24 14:20:11 PDT
Created attachment 350685 [details]
Patch
Comment 7 Ryosuke Niwa 2018-09-24 15:28:28 PDT
Comment on attachment 350685 [details]
Patch

Is this feature somehow enabled in WebKitTestRunner by default?
Comment 8 Justin Michaud 2018-09-24 16:28:11 PDT
Yes. Dean confirmed that for web platform tests, experimental features are enabled by default. We still need the header comment for regular tests though, as far as I know. Also, it doesn't work for webkit 1, which is why I changed the test expectation.
Comment 9 Ryosuke Niwa 2018-09-24 16:37:40 PDT
Comment on attachment 350685 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=350685&action=review

r=me

> LayoutTests/platform/mac-wk1/TestExpectations:625
> +imported/w3c/web-platform-tests/css/css-properties-values-api/ [ Skip ]
>  css-custom-properties-api [ Skip ]

Why is this feature not supported on WK1? That seems like a weird discrepancy.
We certainly shouldn't ship this feature only to WK2.
Comment 10 Justin Michaud 2018-09-24 16:46:06 PDT
It should work in WK1, but the feature flag is not supported because it required a bunch of manual changes to get it to work with the test runner. It didn't seem like it was worth the effort when I was talking with Dean and Simon, at least for now.
Comment 11 WebKit Commit Bot 2018-09-24 17:05:40 PDT
Comment on attachment 350685 [details]
Patch

Clearing flags on attachment: 350685

Committed r236444: <https://trac.webkit.org/changeset/236444>
Comment 12 WebKit Commit Bot 2018-09-24 17:05:41 PDT
All reviewed patches have been landed.  Closing bug.
Comment 13 Radar WebKit Bug Importer 2018-09-24 17:06:21 PDT
<rdar://problem/44746424>