Bug 18964 - object backgrounds should be transparent not white
Summary: object backgrounds should be transparent not white
Status: RESOLVED DUPLICATE of bug 10687
Alias: None
Product: WebKit
Classification: Unclassified
Component: DOM (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh PowerPC OS X 10.5
: P2 Normal
Assignee: Nobody
URL: http://www.peepo.com
Keywords: Regression
Depends on:
Blocks:
 
Reported: 2008-05-09 03:56 PDT by jay
Modified: 2009-07-15 17:40 PDT (History)
2 users (show)

See Also:


Attachments
white bg (140.00 KB, image/tiff)
2008-05-09 23:12 PDT, jay
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description jay 2008-05-09 03:56:06 PDT
object embedded in html should have transparent backgrounds.

last time this bug came around I provided all types of objects. such as applets etc confirming this is not only SVG. Please move to correct component.
Comment 1 Mark Rowe (bdash) 2008-05-09 16:37:02 PDT
The URL you provide does not appear to exhibit the problem you mention.  Can you please either describe how to reproduce the problem using that URL or provide a test case that more obviously demonstrates the issue.
Comment 2 jay 2008-05-09 23:12:27 PDT
Created attachment 21054 [details]
white bg
Comment 3 jay 2008-05-09 23:14:04 PDT
#1

Mark,
as stated I already provided test cases, this is a regression bug.
not sure how to find my closed bugs...

please find attached image grab for safari-webkit using url.
10.5.2 ppc
Comment 4 Mark Rowe (bdash) 2008-05-09 23:31:55 PDT
A regression from what?  In which release or revision did it work correctly?  Safari 3.1.1 and the latest nightly do not look at all like the screenshot you have attached.
Comment 5 jay 2008-05-10 03:42:21 PDT
Mark,
are you using ppc? 

the screenshot is genuine, what can I say?
to confirm:
Version 3.1.1 (5525.18)
r33023

presumably on your machine the document is similar to the attachment without white backkgrounds. if not, how else is it different? do you have a screenshot?
Comment 6 jay 2008-09-04 13:44:05 PDT
bdash

this bug is a regression see #10687
Comment 7 Cameron McCormack 2009-07-15 17:40:29 PDT

*** This bug has been marked as a duplicate of bug 10687 ***