Bug 18921 - REGRESSION: google calendar edit failure
Summary: REGRESSION: google calendar edit failure
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Page Loading (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh Intel OS X 10.5
: P1 Major
Assignee: Nobody
URL:
Keywords: GoogleBug, InRadar, Regression
: 19006 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-05-07 01:37 PDT by toby morris
Modified: 2008-05-29 13:12 PDT (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description toby morris 2008-05-07 01:37:46 PDT
I maintain a google calendar to keep track of help desk activities. For the last 2 nightly builds (I think versions r32901 onwards) I have been unable to edit a component of the calendar.

An item in the calendar needs to be edited (it is just 2 names), when I select that item, and then select the edit function, the page blanks and fails to load... it works on Firefox...

This bug?? is consistent, and has been tried on the last two builds. It is not a spectacular failure and I can always use Firefox for this function, but I thought you should know about it.
Comment 1 Greg Kick 2008-05-07 07:57:31 PDT
I can confirm this behavior.  The following errors are listed:
Refused to set unsafe header Content-Length
Refused to set unsafe header Content-Length
NOT_FOUND_ERR: DOM Exception 8
NOT_FOUND_ERR: DOM Exception 8
Comment 2 mitz 2008-05-12 12:23:41 PDT
*** Bug 19006 has been marked as a duplicate of this bug. ***
Comment 3 mitz 2008-05-12 12:24:06 PDT
<rdar://problem/5928537>
Comment 4 Eric Allen 2008-05-13 09:39:44 PDT
I can confirm it's broken in 32901 and 33029
Comment 5 Eric Allen 2008-05-13 09:46:50 PDT
works in 32877
Comment 6 Eric Allen 2008-05-21 10:05:04 PDT
Still broken in 33943
Comment 7 Jon Sharp 2008-05-22 07:49:43 PDT
Still broken in 34020
Comment 8 Mike Bainter 2008-05-26 11:07:51 PDT
(In reply to comment #0)

Still broken in 34130
 
Comment 9 Dionne 2008-05-28 08:06:51 PDT
I can also confirm this bug for the past two nightly builds. I use Google Calendar exclusively for scheduling, so this bug has been a major thorn in my side. After two builds, I fear I will have to switch back to Firefox soon. :(
Comment 10 Alexey Proskuryakov 2008-05-28 11:58:24 PDT
Does this work for you in shipping Safari/WebKit now?
Comment 11 Eric Allen 2008-05-28 12:05:59 PDT
Works for me in Safari 3.1.1 (5525.18)
Comment 12 Anders Carlsson 2008-05-29 13:12:39 PDT
This was fixed by Alexey in 34197.