Bug 188787 - Do not try to update the compositing policy when not in accelerated compositing mode
Summary: Do not try to update the compositing policy when not in accelerated compositi...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebCore Misc. (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: Gtk, InRadar, Regression
Depends on:
Blocks:
 
Reported: 2018-08-21 05:23 PDT by Carlos Garcia Campos
Modified: 2018-08-22 00:03 PDT (History)
5 users (show)

See Also:


Attachments
Patch (2.18 KB, patch)
2018-08-21 05:25 PDT, Carlos Garcia Campos
simon.fraser: review+
ews: commit-queue-
Details | Formatted Diff | Diff
Archive of layout-test-results from ews202 for win-future (12.83 MB, application/zip)
2018-08-21 19:03 PDT, Build Bot
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Carlos Garcia Campos 2018-08-21 05:23:19 PDT
RenderLayerCompositor::updateCompositingPolicy() is called very often (called from RenderLayerCompositor::cacheAcceleratedCompositingFlags()) and it uses WTF::memoryFootprint() to decide the current compositing policy. Getting the memory footprint is an expensive operation in Linux (and I suspect other non-cocoa ports too), causing an excessive CPU usage. This caused the WPE and GTK+ unit test /webkit/WebKitWebContext/uri-scheme to start timing out in the bots, because the test expects things to happen fast and that's no longer the case. We could reduce the CPU usage a lot by not trying to update the policy when not in accelerated compositing mode. We will need a solution for the AC mode, though.
Comment 1 Carlos Garcia Campos 2018-08-21 05:25:35 PDT
Created attachment 347631 [details]
Patch
Comment 2 Build Bot 2018-08-21 19:03:20 PDT
Comment on attachment 347631 [details]
Patch

Attachment 347631 [details] did not pass win-ews (win):
Output: https://webkit-queues.webkit.org/results/8938508

New failing tests:
http/tests/security/canvas-remote-read-remote-video-blocked-no-crossorigin.html
http/tests/security/video-poster-cross-origin-crash2.html
Comment 3 Build Bot 2018-08-21 19:03:32 PDT
Created attachment 347750 [details]
Archive of layout-test-results from ews202 for win-future

The attached test failures were seen while running run-webkit-tests on the win-ews.
Bot: ews202  Port: win-future  Platform: CYGWIN_NT-6.1-2.10.0-0.325-5-3-x86_64-64bit
Comment 4 Carlos Garcia Campos 2018-08-22 00:01:26 PDT
Committed r235162: <https://trac.webkit.org/changeset/235162>
Comment 5 Radar WebKit Bug Importer 2018-08-22 00:03:30 PDT
<rdar://problem/43595562>